aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libapreq2/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /www/p5-libapreq2/Makefile
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Notes
Diffstat (limited to 'www/p5-libapreq2/Makefile')
-rw-r--r--www/p5-libapreq2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/www/p5-libapreq2/Makefile b/www/p5-libapreq2/Makefile
index 91fbce77d0a5..0691c1f155c0 100644
--- a/www/p5-libapreq2/Makefile
+++ b/www/p5-libapreq2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libapreq2
PORTVERSION= 2.13
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www perl5 devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
@@ -16,7 +16,7 @@ LICENSE= APACHE20
USES= gmake libtool perl5
USE_APACHE= 22+
-USE_PERL5= fixpacklist run
+USE_PERL5= run
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} \
@@ -46,11 +46,10 @@ post-stage:
${RM} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_apreq2*
${RMDIR} -p ${STAGEDIR}${PREFIX}/${APACHEINCLUDEDIR}/apreq2 \
${STAGEDIR}${PREFIX}/${APACHEMODDIR} 2>/dev/null || :
- ${FIND} ${STAGEDIR} -name '*.bs' -type f -size 0c -exec ${RM} {} \;
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/APR/Request/Request.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/APR/Request/Request.so
.for i in Apache2 CGI Cookie Error Hook Param Parser
${STRIP_CMD} \
- ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/APR/Request/${i}/${i}.so
+ ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/APR/Request/${i}/${i}.so
.endfor
.include <bsd.port.mk>