aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libwww
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:51:23 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:51:23 +0000
commitca2c4b42bd5b5ef780ee37c0bc9e9c0a0d81f2d3 (patch)
treec7b6b627dd8b401153b61d3e6f04bc7ce82af306 /www/p5-libwww
parent8bd90cfd46795058288d65854af51f790e834558 (diff)
downloadports-ca2c4b42bd5b5ef780ee37c0bc9e9c0a0d81f2d3.tar.gz
ports-ca2c4b42bd5b5ef780ee37c0bc9e9c0a0d81f2d3.zip
Notes
Diffstat (limited to 'www/p5-libwww')
-rw-r--r--www/p5-libwww/Makefile38
-rw-r--r--www/p5-libwww/distinfo1
-rw-r--r--www/p5-libwww/pkg-comment1
-rw-r--r--www/p5-libwww/pkg-descr55
-rw-r--r--www/p5-libwww/pkg-plist196
5 files changed, 291 insertions, 0 deletions
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
new file mode 100644
index 000000000000..0a4c27268f49
--- /dev/null
+++ b/www/p5-libwww/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-libwww
+# Version required: 5.03
+# Date created: September 30th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= libwww-perl-5.03
+PKGNAME= p5-libwww-5.03
+CATEGORIES+= www
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/URI/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/URI/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/URI/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/URI/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/URI/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/URI/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5 \
+ ${PREFIX}/lib/perl5/site_perl/MD5.pm:${PORTSDIR}/security/p5-MD5 \
+ ${PREFIX}/lib/perl5/site_perl/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in File::CounterFile File::Listing Font::AFM HTML::AsSubs HTML::Element HTML::Entities HTML::FormatPS HTML::FormatText HTML::Formatter HTML::HeadParser HTML::LinkExtor HTML::Parse HTML::Parser HTML::TreeBuilder HTTP::Date HTTP::Headers HTTP::Message HTTP::Negotiate HTTP::Request HTTP::Response HTTP::Status LWP LWP::Debug LWP::IO LWP::MediaTypes LWP::MemberMixin LWP::Protocol LWP::RobotUA LWP::Simple LWP::Socket LWP::TkIO LWP::UserAgent MIME::Base64 MIME::QuotedPrint URI::Escape URI::URL WWW::RobotRules WWW::RobotRules::AnyDBM_File lwpcook; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+ @ for file in lwp-mirror lwp-request lwp-rget; do \
+ gzip -9nf ${PREFIX}/man/man1/$$file.1; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/p5-libwww/distinfo b/www/p5-libwww/distinfo
new file mode 100644
index 000000000000..f0d2360fa757
--- /dev/null
+++ b/www/p5-libwww/distinfo
@@ -0,0 +1 @@
+MD5 (libwww-perl-5.03.tar.gz) = ca42ef9bac3f8d31d04736a4e6cae9b8
diff --git a/www/p5-libwww/pkg-comment b/www/p5-libwww/pkg-comment
new file mode 100644
index 000000000000..bcbbfeb8e117
--- /dev/null
+++ b/www/p5-libwww/pkg-comment
@@ -0,0 +1 @@
+perl5 library for WWW access.
diff --git a/www/p5-libwww/pkg-descr b/www/p5-libwww/pkg-descr
new file mode 100644
index 000000000000..39a416e81f98
--- /dev/null
+++ b/www/p5-libwww/pkg-descr
@@ -0,0 +1,55 @@
+ Libwww-perl is a collection of Perl modules which provides
+ a simple and consistent programming interface (API) to the
+ World-Wide Web. The main focus of the library is to
+ provide classes and functions that allow you to write WWW
+ clients, thus libwww-perl said to be a WWW client library.
+ The library also contain modules that are of more general
+ use.
+
+ The main architecture of the library is object oriented.
+ The user agent, requests sent and responses received from
+ the WWW server are all represented by objects. This makes
+ a simple and powerful interface to these services. The
+ interface should be easy to extend and customize for your
+ needs.
+
+ The main features of the library are:
+
+ o Contains various reuseable components (modules) that
+ can be used separately or together.
+
+ o Provides an object oriented model of HTTP-style
+ communication. Within this framework we currently
+ support access to http, gopher, ftp, news, file, and
+ mailto resources.
+
+ o The library be used through the full object oriented
+ interface or through a very simple procedural
+ interface.
+
+ o Support the basic and digest authorization schemes.
+
+ o Transparent redirect handling.
+
+ o Supports access through proxy servers.
+
+ o URL handling (both absolute and relative URLs are
+ supported).
+
+ o A parser for robots.txt files and a framework for
+ constructing robots.
+
+ o An experimental HTML parser and formatters (for
+ PostScript and plain text).
+
+ o The library can cooperate with Tk. A simple Tk-based
+ GUI browser called 'tkweb' is distributed with the Tk
+ extention for perl.
+
+ o An implementation of the HTTP content negotiation
+ algorithm that can be used both in protocol modules and
+ in server scripts (like CGI scripts).
+
+ o A simple command line client application called lwp-
+ request.
+
diff --git a/www/p5-libwww/pkg-plist b/www/p5-libwww/pkg-plist
new file mode 100644
index 000000000000..b4816267e246
--- /dev/null
+++ b/www/p5-libwww/pkg-plist
@@ -0,0 +1,196 @@
+bin/GET
+bin/HEAD
+bin/POST
+bin/lwp-mirror
+bin/lwp-request
+bin/lwp-rget
+lib/perl5/man/man3/File::CounterFile.3.gz
+lib/perl5/man/man3/File::Listing.3.gz
+lib/perl5/man/man3/Font::AFM.3.gz
+lib/perl5/man/man3/HTML::AsSubs.3.gz
+lib/perl5/man/man3/HTML::Element.3.gz
+lib/perl5/man/man3/HTML::Entities.3.gz
+lib/perl5/man/man3/HTML::FormatPS.3.gz
+lib/perl5/man/man3/HTML::FormatText.3.gz
+lib/perl5/man/man3/HTML::Formatter.3.gz
+lib/perl5/man/man3/HTML::HeadParser.3.gz
+lib/perl5/man/man3/HTML::LinkExtor.3.gz
+lib/perl5/man/man3/HTML::Parse.3.gz
+lib/perl5/man/man3/HTML::Parser.3.gz
+lib/perl5/man/man3/HTML::TreeBuilder.3.gz
+lib/perl5/man/man3/HTTP::Date.3.gz
+lib/perl5/man/man3/HTTP::Headers.3.gz
+lib/perl5/man/man3/HTTP::Message.3.gz
+lib/perl5/man/man3/HTTP::Negotiate.3.gz
+lib/perl5/man/man3/HTTP::Request.3.gz
+lib/perl5/man/man3/HTTP::Response.3.gz
+lib/perl5/man/man3/HTTP::Status.3.gz
+lib/perl5/man/man3/LWP.3.gz
+lib/perl5/man/man3/LWP::Debug.3.gz
+lib/perl5/man/man3/LWP::IO.3.gz
+lib/perl5/man/man3/LWP::MediaTypes.3.gz
+lib/perl5/man/man3/LWP::MemberMixin.3.gz
+lib/perl5/man/man3/LWP::Protocol.3.gz
+lib/perl5/man/man3/LWP::RobotUA.3.gz
+lib/perl5/man/man3/LWP::Simple.3.gz
+lib/perl5/man/man3/LWP::Socket.3.gz
+lib/perl5/man/man3/LWP::TkIO.3.gz
+lib/perl5/man/man3/LWP::UserAgent.3.gz
+lib/perl5/man/man3/MIME::Base64.3.gz
+lib/perl5/man/man3/MIME::QuotedPrint.3.gz
+lib/perl5/man/man3/URI::Escape.3.gz
+lib/perl5/man/man3/URI::URL.3.gz
+lib/perl5/man/man3/WWW::RobotRules.3.gz
+lib/perl5/man/man3/WWW::RobotRules::AnyDBM_File.3.gz
+lib/perl5/man/man3/lwpcook.3.gz
+lib/perl5/site_perl/File/CounterFile.pm
+lib/perl5/site_perl/File/Listing.pm
+lib/perl5/site_perl/Font/AFM.pm
+lib/perl5/site_perl/Font/Metrics/Courier.pm
+lib/perl5/site_perl/Font/Metrics/CourierBold.pm
+lib/perl5/site_perl/Font/Metrics/CourierBoldOblique.pm
+lib/perl5/site_perl/Font/Metrics/CourierOblique.pm
+lib/perl5/site_perl/Font/Metrics/Helvetica.pm
+lib/perl5/site_perl/Font/Metrics/HelveticaBold.pm
+lib/perl5/site_perl/Font/Metrics/HelveticaBoldOblique.pm
+lib/perl5/site_perl/Font/Metrics/HelveticaOblique.pm
+lib/perl5/site_perl/Font/Metrics/TimesBold.pm
+lib/perl5/site_perl/Font/Metrics/TimesBoldItalic.pm
+lib/perl5/site_perl/Font/Metrics/TimesItalic.pm
+lib/perl5/site_perl/Font/Metrics/TimesRoman.pm
+lib/perl5/site_perl/HTML/AsSubs.pm
+lib/perl5/site_perl/HTML/Element.pm
+lib/perl5/site_perl/HTML/Entities.pm
+lib/perl5/site_perl/HTML/FormatPS.pm
+lib/perl5/site_perl/HTML/FormatText.pm
+lib/perl5/site_perl/HTML/Formatter.pm
+lib/perl5/site_perl/HTML/HeadParser.pm
+lib/perl5/site_perl/HTML/LinkExtor.pm
+lib/perl5/site_perl/HTML/Parse.pm
+lib/perl5/site_perl/HTML/Parser.pm
+lib/perl5/site_perl/HTML/TreeBuilder.pm
+lib/perl5/site_perl/HTTP/Date.pm
+lib/perl5/site_perl/HTTP/Headers.pm
+lib/perl5/site_perl/HTTP/Message.pm
+lib/perl5/site_perl/HTTP/Negotiate.pm
+lib/perl5/site_perl/HTTP/Request.pm
+lib/perl5/site_perl/HTTP/Response.pm
+lib/perl5/site_perl/HTTP/Status.pm
+lib/perl5/site_perl/LWP.pm
+lib/perl5/site_perl/LWP/Debug.pm
+lib/perl5/site_perl/LWP/IO.pm
+lib/perl5/site_perl/LWP/MediaTypes.pm
+lib/perl5/site_perl/LWP/MemberMixin.pm
+lib/perl5/site_perl/LWP/Protocol.pm
+lib/perl5/site_perl/LWP/Protocol/file.pm
+lib/perl5/site_perl/LWP/Protocol/ftp.pm
+lib/perl5/site_perl/LWP/Protocol/gopher.pm
+lib/perl5/site_perl/LWP/Protocol/http.pm
+lib/perl5/site_perl/LWP/Protocol/mailto.pm
+lib/perl5/site_perl/LWP/Protocol/nntp.pm
+lib/perl5/site_perl/LWP/RobotUA.pm
+lib/perl5/site_perl/LWP/Simple.pm
+lib/perl5/site_perl/LWP/Socket.pm
+lib/perl5/site_perl/LWP/TkIO.pm
+lib/perl5/site_perl/LWP/UserAgent.pm
+lib/perl5/site_perl/LWP/media.types
+lib/perl5/site_perl/MIME/Base64.pm
+lib/perl5/site_perl/MIME/QuotedPrint.pm
+lib/perl5/site_perl/URI/Escape.pm
+lib/perl5/site_perl/URI/URL.pm
+lib/perl5/site_perl/URI/URL/_generic.pm
+lib/perl5/site_perl/URI/URL/_login.pm
+lib/perl5/site_perl/URI/URL/file.pm
+lib/perl5/site_perl/URI/URL/finger.pm
+lib/perl5/site_perl/URI/URL/ftp.pm
+lib/perl5/site_perl/URI/URL/gopher.pm
+lib/perl5/site_perl/URI/URL/http.pm
+lib/perl5/site_perl/URI/URL/https.pm
+lib/perl5/site_perl/URI/URL/mailto.pm
+lib/perl5/site_perl/URI/URL/news.pm
+lib/perl5/site_perl/URI/URL/nntp.pm
+lib/perl5/site_perl/URI/URL/prospero.pm
+lib/perl5/site_perl/URI/URL/rlogin.pm
+lib/perl5/site_perl/URI/URL/telnet.pm
+lib/perl5/site_perl/URI/URL/tn3270.pm
+lib/perl5/site_perl/URI/URL/wais.pm
+lib/perl5/site_perl/URI/URL/webster.pm
+lib/perl5/site_perl/URI/URL/whois.pm
+lib/perl5/site_perl/WWW/RobotRules.pm
+lib/perl5/site_perl/WWW/RobotRules/AnyDBM_File.pm
+lib/perl5/site_perl/auto/LWP/IO/autosplit.ix
+lib/perl5/site_perl/auto/LWP/IO/read.al
+lib/perl5/site_perl/auto/LWP/IO/write.al
+lib/perl5/site_perl/auto/LWP/UserAgent/_need_proxy.al
+lib/perl5/site_perl/auto/LWP/UserAgent/autosplit.ix
+lib/perl5/site_perl/auto/LWP/UserAgent/clone.al
+lib/perl5/site_perl/auto/LWP/UserAgent/env_proxy.al
+lib/perl5/site_perl/auto/LWP/UserAgent/is_protocol_supported.al
+lib/perl5/site_perl/auto/LWP/UserAgent/mirror.al
+lib/perl5/site_perl/auto/LWP/UserAgent/no_proxy.al
+lib/perl5/site_perl/auto/LWP/UserAgent/proxy.al
+lib/perl5/site_perl/auto/URI/URL/_generic/_netloc_elem.al
+lib/perl5/site_perl/auto/URI/URL/_generic/abs.al
+lib/perl5/site_perl/auto/URI/URL/_generic/autosplit.ix
+lib/perl5/site_perl/auto/URI/URL/_generic/eparams.al
+lib/perl5/site_perl/auto/URI/URL/_generic/epath.al
+lib/perl5/site_perl/auto/URI/URL/_generic/eq.al
+lib/perl5/site_perl/auto/URI/URL/_generic/equery.al
+lib/perl5/site_perl/auto/URI/URL/_generic/frag.al
+lib/perl5/site_perl/auto/URI/URL/_generic/host.al
+lib/perl5/site_perl/auto/URI/URL/_generic/params.al
+lib/perl5/site_perl/auto/URI/URL/_generic/password.al
+lib/perl5/site_perl/auto/URI/URL/_generic/path.al
+lib/perl5/site_perl/auto/URI/URL/_generic/path_components.al
+lib/perl5/site_perl/auto/URI/URL/_generic/port.al
+lib/perl5/site_perl/auto/URI/URL/_generic/query.al
+lib/perl5/site_perl/auto/URI/URL/_generic/rel.al
+lib/perl5/site_perl/auto/URI/URL/_generic/user.al
+lib/perl5/site_perl/auto/URI/URL/abs.al
+lib/perl5/site_perl/auto/URI/URL/as_string.al
+lib/perl5/site_perl/auto/URI/URL/autosplit.ix
+lib/perl5/site_perl/auto/URI/URL/bad_method.al
+lib/perl5/site_perl/auto/URI/URL/base.al
+lib/perl5/site_perl/auto/URI/URL/eq.al
+lib/perl5/site_perl/auto/URI/URL/escape.al
+lib/perl5/site_perl/auto/URI/URL/file/autosplit.ix
+lib/perl5/site_perl/auto/URI/URL/file/dos_path.al
+lib/perl5/site_perl/auto/URI/URL/file/mac_path.al
+lib/perl5/site_perl/auto/URI/URL/file/newlocal.al
+lib/perl5/site_perl/auto/URI/URL/file/unix_path.al
+lib/perl5/site_perl/auto/URI/URL/file/vms_path.al
+lib/perl5/site_perl/auto/URI/URL/http/autosplit.ix
+lib/perl5/site_perl/auto/URI/URL/http/keywords.al
+lib/perl5/site_perl/auto/URI/URL/http/query_form.al
+lib/perl5/site_perl/auto/URI/URL/newlocal.al
+lib/perl5/site_perl/auto/URI/URL/print_on.al
+lib/perl5/site_perl/auto/URI/URL/rel.al
+lib/perl5/site_perl/auto/URI/URL/scheme.al
+lib/perl5/site_perl/auto/URI/URL/strict.al
+lib/perl5/site_perl/auto/URI/URL/unescape.al
+lib/perl5/site_perl/auto/URI/URL/unsafe.al
+lib/perl5/site_perl/lwpcook.pod
+man/man1/lwp-mirror.1.gz
+man/man1/lwp-request.1.gz
+man/man1/lwp-rget.1.gz
+lib/perl5/site_perl/i386-freebsd/auto/libwww-perl/.packlist
+@dirrm lib/perl5/site_perl/File
+@dirrm lib/perl5/site_perl/Font/Metrics
+@dirrm lib/perl5/site_perl/Font
+@dirrm lib/perl5/site_perl/HTTP
+@dirrm lib/perl5/site_perl/LWP/Protocol
+@dirrm lib/perl5/site_perl/LWP
+@dirrm lib/perl5/site_perl/MIME
+@dirrm lib/perl5/site_perl/URI/URL
+@dirrm lib/perl5/site_perl/URI
+@dirrm lib/perl5/site_perl/WWW/RobotRules
+@dirrm lib/perl5/site_perl/WWW
+@dirrm lib/perl5/site_perl/auto/LWP/IO
+@dirrm lib/perl5/site_perl/auto/LWP/UserAgent
+@dirrm lib/perl5/site_perl/auto/LWP
+@dirrm lib/perl5/site_perl/auto/URI/URL/_generic
+@dirrm lib/perl5/site_perl/auto/URI/URL/file
+@dirrm lib/perl5/site_perl/auto/URI/URL/http
+@dirrm lib/perl5/site_perl/auto/URI/URL
+@dirrm lib/perl5/site_perl/auto/URI/
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/libwww-perl