aboutsummaryrefslogtreecommitdiff
path: root/www/p5-pQuery
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-11-25 11:46:52 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-11-25 11:46:52 +0000
commit739673f42c70449a158642457af5634e632a400f (patch)
treed1dc2f9bf10f5927a8610585b3cc107b0e539458 /www/p5-pQuery
parentcaec29276ea2d00b87b7d92e8392156c8985a741 (diff)
downloadports-739673f42c70449a158642457af5634e632a400f.tar.gz
ports-739673f42c70449a158642457af5634e632a400f.zip
Notes
Diffstat (limited to 'www/p5-pQuery')
-rw-r--r--www/p5-pQuery/Makefile25
-rw-r--r--www/p5-pQuery/distinfo3
-rw-r--r--www/p5-pQuery/pkg-descr7
-rw-r--r--www/p5-pQuery/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-pQuery/Makefile b/www/p5-pQuery/Makefile
new file mode 100644
index 000000000000..5e4e1ea01ca9
--- /dev/null
+++ b/www/p5-pQuery/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: www/p5-pQuery
+# Date created: 25 November 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pQuery
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN/../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl Port of jQuery.js
+
+BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= pQuery.3 \
+ pQuery::DOM.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-pQuery/distinfo b/www/p5-pQuery/distinfo
new file mode 100644
index 000000000000..c9f47fa8e480
--- /dev/null
+++ b/www/p5-pQuery/distinfo
@@ -0,0 +1,3 @@
+MD5 (pQuery-0.07.tar.gz) = c8776122dd4209efcc8835813a09ae75
+SHA256 (pQuery-0.07.tar.gz) = 01340c76d5563cfc463e65e2a2a43315c4d7a5d53c627e93426dd19106def2e3
+SIZE (pQuery-0.07.tar.gz) = 56935
diff --git a/www/p5-pQuery/pkg-descr b/www/p5-pQuery/pkg-descr
new file mode 100644
index 000000000000..1147df10ce31
--- /dev/null
+++ b/www/p5-pQuery/pkg-descr
@@ -0,0 +1,7 @@
+pQuery is a pragmatic attempt to port the jQuery JavaScript framework to
+Perl. It is pragmatic in the sense that it switches certain JavaScript
+idioms for Perl ones, in order to make the use of it concise. A primary
+goal of jQuery is to "Find things and do things, concisely". pQuery has
+the same goal.
+
+WWW: http://search.cpan.org/dist/pQuery/
diff --git a/www/p5-pQuery/pkg-plist b/www/p5-pQuery/pkg-plist
new file mode 100644
index 000000000000..b9f0704257a5
--- /dev/null
+++ b/www/p5-pQuery/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/pQuery/.packlist
+%%SITE_PERL%%/pQuery.pm
+%%SITE_PERL%%/pQuery/DOM.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/pQuery
+@dirrmtry %%SITE_PERL%%/pQuery