aboutsummaryrefslogtreecommitdiff
path: root/www/p5-webservice-validator-css-w3c
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 05:54:42 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 05:54:42 +0000
commit09aa9df8a2508b82e189795f6bc3d3e842ed9a40 (patch)
treeb189c292c982ad2cebdd148158353d9cff8e1d18 /www/p5-webservice-validator-css-w3c
parent3a616a067c76a88c43091c87ddfe7ee8156bd1f3 (diff)
downloadports-09aa9df8a2508b82e189795f6bc3d3e842ed9a40.tar.gz
ports-09aa9df8a2508b82e189795f6bc3d3e842ed9a40.zip
Notes
Diffstat (limited to 'www/p5-webservice-validator-css-w3c')
-rw-r--r--www/p5-webservice-validator-css-w3c/Makefile34
-rw-r--r--www/p5-webservice-validator-css-w3c/distinfo2
-rw-r--r--www/p5-webservice-validator-css-w3c/pkg-descr5
-rw-r--r--www/p5-webservice-validator-css-w3c/pkg-plist10
4 files changed, 51 insertions, 0 deletions
diff --git a/www/p5-webservice-validator-css-w3c/Makefile b/www/p5-webservice-validator-css-w3c/Makefile
new file mode 100644
index 000000000000..82bd51cb97d0
--- /dev/null
+++ b/www/p5-webservice-validator-css-w3c/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-webservice-validator-css-w3c
+# Date created: Oct 10, 2005
+# Whom: toni.viemero@iki.fi
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Validator-CSS-W3C
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Experimental interface to the W3C CSS Validation online service
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/QueryParam.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Validator::CSS::W3C.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500802
+IGNORE= This port requires perl 5.8.2 or later.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-webservice-validator-css-w3c/distinfo b/www/p5-webservice-validator-css-w3c/distinfo
new file mode 100644
index 000000000000..86f515737a9b
--- /dev/null
+++ b/www/p5-webservice-validator-css-w3c/distinfo
@@ -0,0 +1,2 @@
+MD5 (WebService-Validator-CSS-W3C-0.02.tar.gz) = 67200ff5ffa97cbeacac1dc33ac0234b
+SIZE (WebService-Validator-CSS-W3C-0.02.tar.gz) = 5940
diff --git a/www/p5-webservice-validator-css-w3c/pkg-descr b/www/p5-webservice-validator-css-w3c/pkg-descr
new file mode 100644
index 000000000000..a51a87aec5f3
--- /dev/null
+++ b/www/p5-webservice-validator-css-w3c/pkg-descr
@@ -0,0 +1,5 @@
+This module is an experimental interface to the W3C CSS Validation online
+service <http://jigsaw.w3.org/css-validator/>, based on its experimental
+SOAP 1.2 support. It helps to find errors in Cascading Style Sheets.
+
+WWW: http://search.cpan.org/dist/WebService-Validator-CSS-W3C/
diff --git a/www/p5-webservice-validator-css-w3c/pkg-plist b/www/p5-webservice-validator-css-w3c/pkg-plist
new file mode 100644
index 000000000000..145d4b6714e4
--- /dev/null
+++ b/www/p5-webservice-validator-css-w3c/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/WebService/Validator/CSS/W3C.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/CSS/W3C/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/CSS/W3C
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/CSS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator/CSS/W3C 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator/CSS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService 2>/dev/null || true