aboutsummaryrefslogtreecommitdiff
path: root/www/peacock/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-05-03 14:26:01 +0000
committerAde Lovett <ade@FreeBSD.org>2000-05-03 14:26:01 +0000
commit87d31418b0baa4dcb9edf1700bb4dac1b3e2fbb0 (patch)
tree8d3e03df896fa3bd1202f874860905f7cfe58efd /www/peacock/Makefile
parentb409f2585087e244bff3f22b3f7cefc9a62cadf2 (diff)
downloadports-87d31418b0baa4dcb9edf1700bb4dac1b3e2fbb0.tar.gz
ports-87d31418b0baa4dcb9edf1700bb4dac1b3e2fbb0.zip
Notes
Diffstat (limited to 'www/peacock/Makefile')
-rw-r--r--www/peacock/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/peacock/Makefile b/www/peacock/Makefile
new file mode 100644
index 000000000000..b540a7c71d8d
--- /dev/null
+++ b/www/peacock/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: peacock
+# Date created: 21st April 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= peacock
+PORTVERSION= 0.1
+CATEGORIES= www gnome
+MASTER_SITES= http://peacock.sourceforge.net/sources/
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib" \
+ GTK_CONFIG="${GTK_CONFIG}"
+
+.include <bsd.port.mk>