aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Server
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-06 17:14:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-06 17:14:36 +0000
commit55272fe62f8330c47c83bd75f357b30de6af0a32 (patch)
tree3f8450140090274425e64125d3e44176572009ba /www/pear-HTTP_Server
parentf6cf619d6cff19373f11e6515758ac02a935021d (diff)
downloadports-55272fe62f8330c47c83bd75f357b30de6af0a32.tar.gz
ports-55272fe62f8330c47c83bd75f357b30de6af0a32.zip
Notes
Diffstat (limited to 'www/pear-HTTP_Server')
-rw-r--r--www/pear-HTTP_Server/Makefile25
-rw-r--r--www/pear-HTTP_Server/distinfo2
-rw-r--r--www/pear-HTTP_Server/pkg-descr5
3 files changed, 32 insertions, 0 deletions
diff --git a/www/pear-HTTP_Server/Makefile b/www/pear-HTTP_Server/Makefile
new file mode 100644
index 000000000000..1797b20016f1
--- /dev/null
+++ b/www/pear-HTTP_Server/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-HTTP_Server
+# Date created: 24 Octobre 2004
+# Whom: Gerrit Beine (<tux@pinguru.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Server
+PORTVERSION= 0.3
+CATEGORIES= www devel pear
+
+MAINTAINER= tux@pinguru.net
+COMMENT= HTTP server class
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
+ ${PEARDIR}/Net/Server.php:${PORTSDIR}/net/pear-Net_Server
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP
+FILES= Server.php Server/Request.php
+EXAMPLES= HTTP_Server_File.php www/index.html
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Server/distinfo b/www/pear-HTTP_Server/distinfo
new file mode 100644
index 000000000000..14fa3808395d
--- /dev/null
+++ b/www/pear-HTTP_Server/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTTP_Server-0.3.tgz) = c2af949c018e3d1428de4679f7f7ce5a
+SIZE (PEAR/HTTP_Server-0.3.tgz) = 5882
diff --git a/www/pear-HTTP_Server/pkg-descr b/www/pear-HTTP_Server/pkg-descr
new file mode 100644
index 000000000000..98787a77fcb5
--- /dev/null
+++ b/www/pear-HTTP_Server/pkg-descr
@@ -0,0 +1,5 @@
+HTTP server class that allows you to easily implement HTTP servers by supplying
+callbacks. The base class will parse the request, call the appropriate callback
+and build a repsonse based on an array that the callbacks have to return.
+
+WWW: http://pear.php.net/package/HTTP_Server/