aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Upload
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 08:56:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 08:56:37 +0000
commitc0fcaf379b661c1f8f4eaeb62c291d52fe6c042e (patch)
tree91081b0816e9c8d8027ec59c1fa699c788322543 /www/pear-HTTP_Upload
parent035feb978b161c4fe436412eb8ccb876be9a4bd7 (diff)
downloadports-c0fcaf379b661c1f8f4eaeb62c291d52fe6c042e.tar.gz
ports-c0fcaf379b661c1f8f4eaeb62c291d52fe6c042e.zip
Notes
Diffstat (limited to 'www/pear-HTTP_Upload')
-rw-r--r--www/pear-HTTP_Upload/Makefile31
-rw-r--r--www/pear-HTTP_Upload/distinfo1
-rw-r--r--www/pear-HTTP_Upload/pkg-descr11
-rw-r--r--www/pear-HTTP_Upload/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/www/pear-HTTP_Upload/Makefile b/www/pear-HTTP_Upload/Makefile
new file mode 100644
index 000000000000..bb76d459f820
--- /dev/null
+++ b/www/pear-HTTP_Upload/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-HTTP_Upload
+# Date created: 13 December 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Upload
+PORTVERSION= 0.8.1
+CATEGORIES= www devel pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Easy and secure managment of files submitted via HTML Forms
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/upload_example.php ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+do-install:
+ @${CP} ${WRKSRC}/Upload.php ${PEARDIR}
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Upload.php
+
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Upload/distinfo b/www/pear-HTTP_Upload/distinfo
new file mode 100644
index 000000000000..7ccf61340220
--- /dev/null
+++ b/www/pear-HTTP_Upload/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/HTTP_Upload-0.8.1.tgz) = 142a87c46988276247a425cf41e6302b
diff --git a/www/pear-HTTP_Upload/pkg-descr b/www/pear-HTTP_Upload/pkg-descr
new file mode 100644
index 000000000000..6ce8f3dac297
--- /dev/null
+++ b/www/pear-HTTP_Upload/pkg-descr
@@ -0,0 +1,11 @@
+This class provides an advanced file uploader system for file uploads made
+from html forms. Features:
+ * Can handle from one file to multiple files.
+ * Safe file copying from tmp dir.
+ * Easy detecting mechanism of valid upload, missing upload or error.
+ * Gives extensive information about the uploaded file.
+ * Rename uploaded files in different ways: as it is, safe or unique
+ * Validate allowed file extensions
+ * Multiple languages error messages support (es, en, de, fr, nl)
+
+WWW: http://pear.php.net/package-info.php?package=HTTP_Upload
diff --git a/www/pear-HTTP_Upload/pkg-plist b/www/pear-HTTP_Upload/pkg-plist
new file mode 100644
index 000000000000..eb5a7bcb3849
--- /dev/null
+++ b/www/pear-HTTP_Upload/pkg-plist
@@ -0,0 +1,5 @@
+%%PEARDIR%%/Upload.php
+%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%DOCSDIR%%/upload_example.php
+@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%