aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_Amazon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-16 23:27:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-16 23:27:26 +0000
commit9ce71fd5c32f86ae985e38e376eae4717fece204 (patch)
treeddc2fe54b2e76845b81cbb3a18376069015324aa /www/pear-Services_Amazon
parent1e99da44f1def3d6165d18ef6e3eefaeeb141564 (diff)
downloadports-9ce71fd5c32f86ae985e38e376eae4717fece204.tar.gz
ports-9ce71fd5c32f86ae985e38e376eae4717fece204.zip
Notes
Diffstat (limited to 'www/pear-Services_Amazon')
-rw-r--r--www/pear-Services_Amazon/Makefile30
-rw-r--r--www/pear-Services_Amazon/distinfo3
-rw-r--r--www/pear-Services_Amazon/pkg-descr3
3 files changed, 36 insertions, 0 deletions
diff --git a/www/pear-Services_Amazon/Makefile b/www/pear-Services_Amazon/Makefile
new file mode 100644
index 000000000000..2c8ac9c00284
--- /dev/null
+++ b/www/pear-Services_Amazon/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Services_Amazon
+# Date created: 11 May,2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Amazon
+PORTVERSION= 0.8.0
+CATEGORIES= www pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= PHP interface to Amazon Product Advertising API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Amazon.php AmazonECS4.php
+EXAMPLES= amazon_ecs4_cache.php \
+ amazon_ecs4_cart.php \
+ amazon_ecs4_itemsearch.php \
+ amazon_example1.php \
+ config.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Amazon/distinfo b/www/pear-Services_Amazon/distinfo
new file mode 100644
index 000000000000..48cd718f5bf1
--- /dev/null
+++ b/www/pear-Services_Amazon/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Amazon-0.8.0.tgz) = 96a663a160ea48d7a89af54270d9d3d1
+SHA256 (PEAR/Services_Amazon-0.8.0.tgz) = 5f79d770e7d45da92c2b7985d0aaada6f9e4aca998723c4d2f969abcc808433f
+SIZE (PEAR/Services_Amazon-0.8.0.tgz) = 20992
diff --git a/www/pear-Services_Amazon/pkg-descr b/www/pear-Services_Amazon/pkg-descr
new file mode 100644
index 000000000000..27b14c38f8a2
--- /dev/null
+++ b/www/pear-Services_Amazon/pkg-descr
@@ -0,0 +1,3 @@
+pear-Services_Amazon is a PHP interface to Amazon Product Advertising API.
+
+WWW: http://pear.php.net/package/Services_Amazon/