aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_Amazon_S3
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-07 13:27:02 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-07 13:27:02 +0000
commitf796c36c1a63c4dd6464b4d8c5e03e8366f22abb (patch)
tree77d739dfa8d8674419c93b04e4cce840d3249cd7 /www/pear-Services_Amazon_S3
parent3b29dca127c36be3cc01f05c8b39a3cb2696df47 (diff)
downloadports-f796c36c1a63c4dd6464b4d8c5e03e8366f22abb.tar.gz
ports-f796c36c1a63c4dd6464b4d8c5e03e8366f22abb.zip
Notes
Diffstat (limited to 'www/pear-Services_Amazon_S3')
-rw-r--r--www/pear-Services_Amazon_S3/Makefile43
-rw-r--r--www/pear-Services_Amazon_S3/distinfo3
-rw-r--r--www/pear-Services_Amazon_S3/pkg-descr5
3 files changed, 51 insertions, 0 deletions
diff --git a/www/pear-Services_Amazon_S3/Makefile b/www/pear-Services_Amazon_S3/Makefile
new file mode 100644
index 000000000000..bdefe9fec8ac
--- /dev/null
+++ b/www/pear-Services_Amazon_S3/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: pear-Services_Amazon_S3
+# Date created: 23 Nov ,2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Amazon_S3
+PORTVERSION= 0.3.0
+CATEGORIES= www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PHP API for Amazon S3 (Simple Storage Service)
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2 \
+ ${PEARDIR}/Crypt/HMAC2.php:${PORTSDIR}/security/pear-Crypt_HMAC2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= spl
+
+CATEGORY= Services
+FILES= Amazon/S3.php \
+ Amazon/S3/AccessControlList.php \
+ Amazon/S3/AccessDeniedException.php\
+ Amazon/S3/Exception.php \
+ Amazon/S3/NotFoundException.php \
+ Amazon/S3/ObjectIterator.php \
+ Amazon/S3/Prefix.php \
+ Amazon/S3/Resource/Bucket.php \
+ Amazon/S3/Resource/Object.php \
+ Amazon/S3/Resource.php \
+ Amazon/S3/ServerErrorException.php \
+ Amazon/S3/Stream.php
+TESTS= AllTests.php StreamTest.php\
+ Test.php config.php.dist
+
+post-extract:
+ @cd ${WRKSRC} && ${MV} Services/Amazon .
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Amazon_S3/distinfo b/www/pear-Services_Amazon_S3/distinfo
new file mode 100644
index 000000000000..e98b817e7ddf
--- /dev/null
+++ b/www/pear-Services_Amazon_S3/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Amazon_S3-0.3.0.tgz) = d9330acb064188e969e2316d9ed0ff9c
+SHA256 (PEAR/Services_Amazon_S3-0.3.0.tgz) = 005ba6d64e9eff1f282226a1ee620d1ccf2edffe2dc99cdf6aea086a57cb3bb7
+SIZE (PEAR/Services_Amazon_S3-0.3.0.tgz) = 29421
diff --git a/www/pear-Services_Amazon_S3/pkg-descr b/www/pear-Services_Amazon_S3/pkg-descr
new file mode 100644
index 000000000000..53c65693eeec
--- /dev/null
+++ b/www/pear-Services_Amazon_S3/pkg-descr
@@ -0,0 +1,5 @@
+pear-Services_Amazon_S3 provides an object-oriented interface
+to the Amazon Simple Storage Service (S3). This package is
+based on the 2006-03-01 REST API.
+
+WWW: http://pear.php.net/package/Services_Amazon_S3/