aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_Digg
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-29 16:11:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-29 16:11:01 +0000
commit3d51811e7c41b47f66a5920c9fe20224c725ba27 (patch)
tree5e1883bba9d983e6a42cf82f5683bce68d63da9a /www/pear-Services_Digg
parentc156112be47f3adbb8d97ebc4e55fc5580924284 (diff)
downloadports-3d51811e7c41b47f66a5920c9fe20224c725ba27.tar.gz
ports-3d51811e7c41b47f66a5920c9fe20224c725ba27.zip
Notes
Diffstat (limited to 'www/pear-Services_Digg')
-rw-r--r--www/pear-Services_Digg/Makefile50
-rw-r--r--www/pear-Services_Digg/distinfo3
-rw-r--r--www/pear-Services_Digg/pkg-descr4
3 files changed, 57 insertions, 0 deletions
diff --git a/www/pear-Services_Digg/Makefile b/www/pear-Services_Digg/Makefile
new file mode 100644
index 000000000000..fbd9704acc7f
--- /dev/null
+++ b/www/pear-Services_Digg/Makefile
@@ -0,0 +1,50 @@
+# Ports collection makefile for: pear-Services_Digg
+# Date created: 17 May 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Digg
+PORTVERSION= 0.1.0
+CATEGORIES= www pear
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= PHP interface to Digg's API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= curl
+
+CATEGORY= Services
+FILES= Digg.php Digg/Comments.php Digg/Comment.php Digg/Common.php \
+ Digg/Errors.php Digg/Exception.php Digg/Proxy.php Digg/Response.php \
+ Digg/Stories.php Digg/Story.php Digg/Topics.php Digg/User.php \
+ Digg/Users.php Digg/Response/Common.php Digg/Response/php.php \
+ Digg/Response/xml.php
+
+TESTS= 000-services-digg-factory.phpt 001-errors-getAll.phpt \
+ 003-errors-getErrorByCode.phpt 005-topics-getAll.phpt \
+ 010-user-submissions.phpt 011-user-isFriend.phpt \
+ 012-user-isFan.phpt 013-user-comments.phpt \
+ 014-user-diggs.phpt 020-users-getUserByName.phpt \
+ 030-stories-getStoryById.phpt 031-stories-getContainer.phpt \
+ 032-stories-getContainerPopular.phpt \
+ 032-stories-getContainerUpcoming.phpt \
+ 033-stories-getStoriesById.phpt 034-stories-comments.phpt \
+ 034-stories-diggs.phpt 034-stories-popular.phpt \
+ 035-stories-getAll.phpt 035-stories-getStoriesComments.phpt \
+ 035-stories-getStoriesDiggs.phpt 036-stories-getStoryByTitle.phpt \
+ 040-story-comments.phpt 050-comments.phpt 060-comment-replies.phpt \
+ 070-proxy-get.phpt 071-proxy-post.phpt \
+ 200-diggapiuser-isFriend.phpt 201-diggapistories-iteration.phpt \
+ tests-config.php
+
+post-extract:
+ ${MV} ${WRKSRC}/Services/Digg.php ${WRKSRC}
+ ${MV} ${WRKSRC}/Services/Digg ${WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Digg/distinfo b/www/pear-Services_Digg/distinfo
new file mode 100644
index 000000000000..f9bbb971b4d0
--- /dev/null
+++ b/www/pear-Services_Digg/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Digg-0.1.0.tgz) = 0e5bfce998b222c626107a6b70633e4f
+SHA256 (PEAR/Services_Digg-0.1.0.tgz) = 4b171dfae812829e53df5fee6ee137955a2d4d899d156cd204753a7146201df4
+SIZE (PEAR/Services_Digg-0.1.0.tgz) = 13677
diff --git a/www/pear-Services_Digg/pkg-descr b/www/pear-Services_Digg/pkg-descr
new file mode 100644
index 000000000000..184a78aa9e83
--- /dev/null
+++ b/www/pear-Services_Digg/pkg-descr
@@ -0,0 +1,4 @@
+An interface for accessing Digg's web services API
+at http://services.digg.com.
+
+WWW: http://pear.php.net/package/Services_Digg/