aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_TinyURL
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-23 14:21:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-23 14:21:09 +0000
commit2f747b6048f4adf133b3feb939f31d5b6d3733f3 (patch)
tree86399a09dcfdd2d70cad6fffa9fbf13bab5a0dea /www/pear-Services_TinyURL
parentdd80923edf4e82214394212c74b00581fbdb8438 (diff)
downloadports-2f747b6048f4adf133b3feb939f31d5b6d3733f3.tar.gz
ports-2f747b6048f4adf133b3feb939f31d5b6d3733f3.zip
Notes
Diffstat (limited to 'www/pear-Services_TinyURL')
-rw-r--r--www/pear-Services_TinyURL/Makefile27
-rw-r--r--www/pear-Services_TinyURL/distinfo3
-rw-r--r--www/pear-Services_TinyURL/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/www/pear-Services_TinyURL/Makefile b/www/pear-Services_TinyURL/Makefile
new file mode 100644
index 000000000000..6814f6123f7d
--- /dev/null
+++ b/www/pear-Services_TinyURL/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Services_TinyURL
+# Date created: 22 Jan 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_TinyURL
+PORTVERSION= 0.1.2
+CATEGORIES= www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= PHP interface to TinyURL's API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+USE_PHP= curl
+
+FILES= Services/TinyURL.php Services/TinyURL/Exception.php
+
+TESTS= 001-create.phpt 002-lookup.phpt 003-create-and-lookup.phpt \
+ 100-bug-12207.phpt tests-config.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_TinyURL/distinfo b/www/pear-Services_TinyURL/distinfo
new file mode 100644
index 000000000000..1605baff9eec
--- /dev/null
+++ b/www/pear-Services_TinyURL/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_TinyURL-0.1.2.tgz) = 40cf7a8225ff55db877df9ac3f9f6cd1
+SHA256 (PEAR/Services_TinyURL-0.1.2.tgz) = f7c07f8016edd37cef9e87465b6ab9cefafec83c5d3d04ecda5427d52eb56500
+SIZE (PEAR/Services_TinyURL-0.1.2.tgz) = 3960
diff --git a/www/pear-Services_TinyURL/pkg-descr b/www/pear-Services_TinyURL/pkg-descr
new file mode 100644
index 000000000000..6e826f7bd5d9
--- /dev/null
+++ b/www/pear-Services_TinyURL/pkg-descr
@@ -0,0 +1,4 @@
+An interface for creating TinyURL's with their API as well as looking up
+destinations of given TinyURL's.
+
+WWW: http://pear.php.net/package/Services_TinyURL/