aboutsummaryrefslogtreecommitdiff
path: root/www/pebble
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 23:11:33 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 23:11:33 +0000
commita36cc6f76069b486e45004dd475af0181e2d50a3 (patch)
tree980687f44e6ea0b8061f73b70997b5ed094b78d7 /www/pebble
parentf093667af6bed85e379cf39682c94edcbfba0c61 (diff)
downloadports-a36cc6f76069b486e45004dd475af0181e2d50a3.tar.gz
ports-a36cc6f76069b486e45004dd475af0181e2d50a3.zip
Notes
Diffstat (limited to 'www/pebble')
-rw-r--r--www/pebble/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/www/pebble/Makefile b/www/pebble/Makefile
index 3eb76a94e250..830cdf5735e4 100644
--- a/www/pebble/Makefile
+++ b/www/pebble/Makefile
@@ -28,12 +28,12 @@ SUB_FILES= pebble.properties pkg-message
PKGMESSAGE= ${WRKSRC}/pkg-message
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= configuration.html credits.html images index.html \
installation.html license.txt multiblog.html screen.css \
screenshots.html security.html upgrading1x.html \
upgrading2x.html
-.endif
PLIST_FILES= ${WEBAPP_SUBDIR}/${PORTNAME}.war
PEBBLE_CONTEXT= WEB-INF/applicationContext-pebble.xml
@@ -43,17 +43,12 @@ do-patch:
cd ${WRKSRC} && ${LOCALBASE}/bin/zip -u pebble.war ${PEBBLE_CONTEXT}
do-install:
- ${MKDIR} "${STAGEDIR}${PEBBLE_HOME}"
+ @${MKDIR} "${STAGEDIR}${PEBBLE_HOME}"
${CHOWN} "www:www" "${STAGEDIR}${PEBBLE_HOME}"
${INSTALL_DATA} ${WRKDIR}/pebble.properties ${STAGEDIR}${PEBBLE_PROPERTIES}.sample
- ${MKDIR} ${STAGEDIR}${WEBAPP_DIR}
+ @${MKDIR} ${STAGEDIR}${WEBAPP_DIR}
${INSTALL_DATA} ${WRKSRC}/pebble.war ${STAGEDIR}${WEBAPP_DIR}/${PORTNAME}.war
-.if !defined(NOPORTDOCS)
cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \;
cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
-.endif
-
-post-install:
- ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>