aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-APC
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-03-01 07:30:34 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-03-01 07:30:34 +0000
commit9b454c1ec1bf16f321090074445a3da40790e640 (patch)
tree2600f41f3e8589152bc2082fabbf85cb8bf8ee30 /www/pecl-APC
parent421d477a9791e8d5d57edd6207a641f404da8402 (diff)
downloadports-9b454c1ec1bf16f321090074445a3da40790e640.tar.gz
ports-9b454c1ec1bf16f321090074445a3da40790e640.zip
Notes
Diffstat (limited to 'www/pecl-APC')
-rw-r--r--www/pecl-APC/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index d5a941593032..6db97265a31e 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= APC
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -26,12 +27,23 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-apc
-OPTIONS= MMAP "Enable mmap" off
+OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
+ SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
+
+.include <bsd.port.pre.mk>
+
+.if ${PHP_VER} == 5
+BROKEN= This port is not compatible with php${PHP_VER}
+.endif
.if !defined(WITHOUT_MMAP)
CONFIGURE_ARGS+= --enable-mmap
.endif
+.if !defined(WITHOUT_SEMAPHORES)
+CONFIGURE_ARGS+= --enable-sem
+.endif
+
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
@@ -45,4 +57,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>