aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-http
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-25 22:53:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-25 22:53:58 +0000
commit6f190c5050ae166fb2f2ead6c8d8aaab5d76379a (patch)
tree076a5b16b32c6ea1982247633d0edaf2ec68d295 /www/pecl-http
parentc49aa45d66af603bb5993ab0a5acc8ae5d03de44 (diff)
downloadports-6f190c5050ae166fb2f2ead6c8d8aaab5d76379a.tar.gz
ports-6f190c5050ae166fb2f2ead6c8d8aaab5d76379a.zip
Notes
Diffstat (limited to 'www/pecl-http')
-rw-r--r--www/pecl-http/Makefile28
-rw-r--r--www/pecl-http/distinfo3
-rw-r--r--www/pecl-http/pkg-descr10
3 files changed, 41 insertions, 0 deletions
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
new file mode 100644
index 000000000000..b501653a2c03
--- /dev/null
+++ b/www/pecl-http/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pecl-http
+# Date created: 23 July 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http
+PORTVERSION= 1.6.1
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= pecl_${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Extended HTTP Support
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS+= --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-magic-mime
+
+.include <bsd.port.mk>
diff --git a/www/pecl-http/distinfo b/www/pecl-http/distinfo
new file mode 100644
index 000000000000..475c5275544a
--- /dev/null
+++ b/www/pecl-http/distinfo
@@ -0,0 +1,3 @@
+MD5 (pecl_http-1.6.1.tgz) = 72f6a0b0d9e4ddc56ed964609e26ec2c
+SHA256 (pecl_http-1.6.1.tgz) = 4961b12c335d2d8c2e0047da812d97b922db049e2ac57cf29b041f8db2f571b6
+SIZE (pecl_http-1.6.1.tgz) = 172539
diff --git a/www/pecl-http/pkg-descr b/www/pecl-http/pkg-descr
new file mode 100644
index 000000000000..172f458595f3
--- /dev/null
+++ b/www/pecl-http/pkg-descr
@@ -0,0 +1,10 @@
+pecl-http extension aims to provide a convenient and
+powerful set of functionality for one of PHPs major
+applications. It eases handling of HTTP URLs, dates,
+redirects, headers and messages, provides means for
+negotiation of clients preferred language and charset,
+as well as a convenient way to send any arbitrary data
+with caching and resuming capabilities. It provides
+powerful request functionality too.
+
+WWW: http://pecl.php.net/package/pecl_http/