aboutsummaryrefslogtreecommitdiff
path: root/www/perlbal/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-10-18 02:46:23 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-10-18 02:46:23 +0000
commit9a868e57ab01b00ce1cf0ecb883eda05ef9e23cd (patch)
tree647ea73debd9f66284de8b5d5a76d11f060ed6cc /www/perlbal/Makefile
parent0b2143107d81024ba01f62dbba67b423b57288bd (diff)
Add perlbal 1.36, reverse-proxy load balancer and webserver.
PR: ports/75369 Submitted by: Jacques Marneweck <jacques@php.net>
Notes
Notes: svn path=/head/; revision=145707
Diffstat (limited to 'www/perlbal/Makefile')
-rw-r--r--www/perlbal/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/perlbal/Makefile b/www/perlbal/Makefile
new file mode 100644
index 000000000000..a079244310c3
--- /dev/null
+++ b/www/perlbal/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Danga-Socket
+# Date created: 2005-08-08
+# Whom: Jacques Marneweck <jacques@php.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perlbal
+PORTVERSION= 1.36
+CATEGORIES= www
+MASTER_SITES= http://www.danga.com/dist/Perlbal/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jacques@php.net
+COMMENT= Reverse-proxy load balancer and webserver
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/BSD/Resource.pm:${PORTSDIR}/devel/p5-BSD-Resource \
+ p5-Danga-Socket>=1.44:${PORTSDIR}/devel/p5-Danga-Socket \
+ ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= perlbal.1
+MAN3= Perlbal.3
+
+.include <bsd.port.mk>