aboutsummaryrefslogtreecommitdiff
path: root/www/perlbal/Makefile
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2009-06-26 11:51:46 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2009-06-26 11:51:46 +0000
commit111fcc280e3d02644f9a52c1d871ec209099f5f5 (patch)
tree1f3c6fb5b2c36226a85543cef64ee1370c6b8e73 /www/perlbal/Makefile
parent9004d89c859dec2213aed2db106d6509a1641a2c (diff)
downloadports-111fcc280e3d02644f9a52c1d871ec209099f5f5.tar.gz
ports-111fcc280e3d02644f9a52c1d871ec209099f5f5.zip
Notes
Diffstat (limited to 'www/perlbal/Makefile')
-rw-r--r--www/perlbal/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/perlbal/Makefile b/www/perlbal/Makefile
index 50d534c99d46..89cf421f2737 100644
--- a/www/perlbal/Makefile
+++ b/www/perlbal/Makefile
@@ -6,28 +6,28 @@
#
PORTNAME= Perlbal
-PORTVERSION= 1.70
-PORTREVISION= 1
+PORTVERSION= 1.72
CATEGORIES= www
-MASTER_SITES= http://www.danga.com/dist/Perlbal/ \
- http://www.powertrip.co.za/distfiles/danga/
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Reverse-proxy load balancer and webserver
-RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/BSD/Resource.pm:${PORTSDIR}/devel/p5-BSD-Resource \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BSD/Resource.pm:${PORTSDIR}/devel/p5-BSD-Resource \
${SITE_PERL}/Danga/Socket.pm:${PORTSDIR}/devel/p5-Danga-Socket \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= perlbal.1
-MAN3= Perlbal.3 Perlbal::Plugin::Palimg.3 \
+MAN3= Perlbal.3 \
+ Perlbal::Plugin::Palimg.3 \
Perlbal::Plugin::Cgilike.3 \
Perlbal::Plugin::Include.3 \
+ Perlbal::Test.3 \
Perlbal::Util.3
.include <bsd.port.pre.mk>
@@ -36,8 +36,8 @@ MAN3= Perlbal.3 Perlbal::Plugin::Palimg.3 \
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
.endif
-post-install:
.ifndef NOPORTDOCS
+post-install:
${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
.endif