aboutsummaryrefslogtreecommitdiff
path: root/www/pgdriver
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2001-09-03 10:09:55 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2001-09-03 10:09:55 +0000
commit2f0c6d8518e24fb05724e1172d9c82a37960e9bd (patch)
treeaa9a2d4c993f1496f375b2c351e541176b724771 /www/pgdriver
parent26eb9e86d0d0cb065a409d783f350c11f4583ab8 (diff)
downloadports-2f0c6d8518e24fb05724e1172d9c82a37960e9bd.tar.gz
ports-2f0c6d8518e24fb05724e1172d9c82a37960e9bd.zip
Notes
Diffstat (limited to 'www/pgdriver')
-rw-r--r--www/pgdriver/Makefile8
-rw-r--r--www/pgdriver/distinfo2
-rw-r--r--www/pgdriver/files/patch-aa35
-rw-r--r--www/pgdriver/files/patch-ab11
4 files changed, 23 insertions, 33 deletions
diff --git a/www/pgdriver/Makefile b/www/pgdriver/Makefile
index 7afd9ade8313..519587a8242d 100644
--- a/www/pgdriver/Makefile
+++ b/www/pgdriver/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= pgdriver
-PORTVERSION= 1.1
+PORTVERSION= 2.0
CATEGORIES= www databases
-MASTER_SITES= http://openacs.org/sdm/download-package/2/20/
+MASTER_SITES= http://openacs.org/sdm/download-package/2/38/
+EXTRACT_SUFX= .tgz
MAINTAINER= jkoshy@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
- ${LOCALBASE}/pgsql/bin/postmaster:${PORTSDIR}/databases/postgresql7
+ ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql7
RUN_DEPENDS= ${BUILD_DEPENDS}
MAKEFILE= makefile
+MAKE_ENV+= PREFIX=${PREFIX}
.include <bsd.port.mk>
diff --git a/www/pgdriver/distinfo b/www/pgdriver/distinfo
index 5171d31211db..a1ad5bcf4b46 100644
--- a/www/pgdriver/distinfo
+++ b/www/pgdriver/distinfo
@@ -1 +1 @@
-MD5 (pgdriver-1.1.tar.gz) = c7fb77755fe12f51929b8370b35141fc
+MD5 (pgdriver-2.0.tgz) = 12bcbc30fe5795e3f0bf656b6d4bf6c0
diff --git a/www/pgdriver/files/patch-aa b/www/pgdriver/files/patch-aa
index cae7084d2bfa..702f51fb22a8 100644
--- a/www/pgdriver/files/patch-aa
+++ b/www/pgdriver/files/patch-aa
@@ -1,31 +1,30 @@
---- makefile-- Thu Mar 1 12:44:27 2001
-+++ makefile Thu Mar 1 12:46:38 2001
-@@ -33,15 +33,15 @@
+--- makefile-- Mon May 14 06:41:27 2001
++++ makefile Mon Sep 3 15:37:38 2001
+@@ -32,21 +32,22 @@
+ # - Added a commented-out block showing settings for Debian/GNU Linux with
# package installed AOLserver and PostgreSQL
+-INSTALL=/home/nsadmin
++INSTALL=${NSHOME}
+
# Location of the PostgreSQL libraries
--#PGLIB=/usr/local/pgsql/lib
-+PGLIB=/usr/local/pgsql/lib
+-PGLIB=/usr/local/pgsql/lib
++PGLIB=${PREFIX}/lib
# Location of the PostgreSQL includes
--#PGINC=/usr/local/pgsql/include
-+PGINC=/usr/local/pgsql/include
+-PGINC=/usr/local/pgsql/include
++PGINC=${PREFIX}/include/pgsql
# Location of the AOLserver files (normally the ~nsadmin directory):
#NSHOME=/opt/aolserver
# Alternate location for AOLserver
--#NSHOME=/usr/local/AOLserver
-+NSHOME=/usr/local/aolserver
+-NSHOME=/home/aolserver/aolserver3_0
++NSHOME=${PREFIX}/aolserver
CC=gcc
- COPTS=-Wall -fpic -shared -I/usr/local/pgsql/include -I/home/nsadmin/include -I-/usr/include
-@@ -82,8 +82,8 @@
- # FreeBSD 3
- # The make install target isn't what you want---just copy postgres.so to
- # /usr/local/libexec/aolserver
--#COPTS=-g -Wall -fpic -pthread -D_THREAD_SAFE -I/usr/local/include/aolserver -I/usr/local/pgsql/include
--#LDFLAGS=-pthread -Wl,-E
-+COPTS=-g -Wall -fpic -pthread -D_THREAD_SAFE -I${NSHOME}/include -I${PGINC}
+-COPTS=-Wall -fpic -shared -I/usr/local/pgsql/include -I/home/aolserver/include -I-/usr/include
++COPTS=-Wall -fpic -shared -I${PGINC} -I${NSNOME}/include -I-/usr/include
+LDFLAGS=-pthread -Wl,-E
- # You should not need to edit anything below this line.
+ # Debian Linux with deb AOLserver & PostgreSQL
+ #CC=gcc
diff --git a/www/pgdriver/files/patch-ab b/www/pgdriver/files/patch-ab
deleted file mode 100644
index 50499b177c6e..000000000000
--- a/www/pgdriver/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- postgres.c-- Fri Jun 30 01:42:10 2000
-+++ postgres.c Thu Mar 1 14:41:54 2001
-@@ -1139,7 +1139,7 @@
- char* filename)
- {
- int fd, i, j, segment, readlen;
-- char in_buf[6000], out_buf[8000], query[100];
-+ char in_buf[6001], out_buf[8001], query[8100];
- char *segment_pos;
-
- fd = open (filename, O_RDONLY);