aboutsummaryrefslogtreecommitdiff
path: root/www/photo_gallery
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 09:59:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 09:59:48 +0000
commita1c71d1ab24330a5338cbc656a856843d03de94b (patch)
tree2c7fd0a0c6287fbaaa43cd0168d001180086ed2b /www/photo_gallery
parent7f535593db388b19dc61526c357cb62237b85176 (diff)
downloadports-a1c71d1ab24330a5338cbc656a856843d03de94b.tar.gz
ports-a1c71d1ab24330a5338cbc656a856843d03de94b.zip
Notes
Diffstat (limited to 'www/photo_gallery')
-rw-r--r--www/photo_gallery/Makefile35
-rw-r--r--www/photo_gallery/distinfo1
-rw-r--r--www/photo_gallery/pkg-descr5
-rw-r--r--www/photo_gallery/pkg-plist6
4 files changed, 47 insertions, 0 deletions
diff --git a/www/photo_gallery/Makefile b/www/photo_gallery/Makefile
new file mode 100644
index 000000000000..100885de5ae6
--- /dev/null
+++ b/www/photo_gallery/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: photo_gallery
+# Date created: Feb 5 2003
+# Whom: Bob Bomar <bob@bomar.us>
+#
+# $FreeBSD$
+
+PORTNAME= photo_gallery
+PORTVERSION= 1.3
+CATEGORIES= www
+MASTER_SITES= http://www.capybara.org/~dfraser/photo_gallery/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tar
+
+MAINTAINER= bob@bomar.us
+COMMENT= Simple web based photo gallery
+
+RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm\
+ ${LOCALBASE}/etc/apache/httpd.conf:${PORTSDIR}/www/apache13\
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info\
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+
+WEBOWN?= www
+WEBGRP?= www
+APACHEDIR= ${LOCALBASE}/www/data
+INSTALLDIR= ${APACHEDIR}/photo_gallery
+NO_BUILD= yes
+USE_PERL5= yes
+USE_GZIP= no
+
+do-install:
+ ${MKDIR} ${INSTALLDIR}
+ cd ${WRKSRC}; ${FIND} . \
+ | cpio -pdm -R ${WEBOWN}:${WEBGRP} ${INSTALLDIR}
+.include <bsd.port.mk>
diff --git a/www/photo_gallery/distinfo b/www/photo_gallery/distinfo
new file mode 100644
index 000000000000..25c0de9cf759
--- /dev/null
+++ b/www/photo_gallery/distinfo
@@ -0,0 +1 @@
+MD5 (photo_gallery_1.3.tar) = ea6b3bde15db54a927f1a28b566bcbad
diff --git a/www/photo_gallery/pkg-descr b/www/photo_gallery/pkg-descr
new file mode 100644
index 000000000000..03b35ced0029
--- /dev/null
+++ b/www/photo_gallery/pkg-descr
@@ -0,0 +1,5 @@
+Project, event or category(whatever you call) base photo gallery
+with admin and frontend screen. Automatic thumbnail generation.
+
+WWW: http://www.capybara.org/~dfraser/photo_gallery/
+-Bob Bomar <bob@bomar.us>
diff --git a/www/photo_gallery/pkg-plist b/www/photo_gallery/pkg-plist
new file mode 100644
index 000000000000..5b151f25a2e9
--- /dev/null
+++ b/www/photo_gallery/pkg-plist
@@ -0,0 +1,6 @@
+www/data/photo_gallery/index.cgi
+www/data/photo_gallery/previews.cgi
+www/data/photo_gallery/readme.html
+www/data/photo_gallery/.header.html
+www/data/photo_gallery/.footer.html
+@dirrm www/data/photo_gallery