aboutsummaryrefslogtreecommitdiff
path: root/www/php-screw
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-11-04 11:54:17 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-11-04 11:54:17 +0000
commitd0778a903395f6643343d40c9f2054d153be046a (patch)
tree514a65f2b16dd6cbc59ea3eb69a5c5116885a063 /www/php-screw
parentd1957b145f797c899901fa560f0db01453a84656 (diff)
downloadports-d0778a903395f6643343d40c9f2054d153be046a.tar.gz
ports-d0778a903395f6643343d40c9f2054d153be046a.zip
Notes
Diffstat (limited to 'www/php-screw')
-rw-r--r--www/php-screw/Makefile4
-rw-r--r--www/php-screw/files/patch-tools::screw.c42
2 files changed, 42 insertions, 4 deletions
diff --git a/www/php-screw/Makefile b/www/php-screw/Makefile
index 158d99364577..65b9619aa2d6 100644
--- a/www/php-screw/Makefile
+++ b/www/php-screw/Makefile
@@ -27,10 +27,6 @@ CONFIGURE_ARGS+=--enable-php_screw=shared
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
pre-everything::
@${ECHO} ""
@${ECHO} "To achieve real security, define your own encryption"
diff --git a/www/php-screw/files/patch-tools::screw.c b/www/php-screw/files/patch-tools::screw.c
new file mode 100644
index 000000000000..f9236b30f103
--- /dev/null
+++ b/www/php-screw/files/patch-tools::screw.c
@@ -0,0 +1,42 @@
+--- tools/screw.c.orig Sun Aug 31 00:55:45 2003
++++ tools/screw.c Sun Aug 31 00:56:14 2003
+@@ -18,12 +18,12 @@
+
+ if (argc != 2) {
+ fprintf(stderr, "Usage: filename.\n");
+- exit();
++ exit(1);
+ }
+ fp = fopen(argv[1], "r");
+ if (fp == NULL) {
+ fprintf(stderr, "File not found(%s)\n", argv[1]);
+- exit();
++ exit(1);
+ }
+
+ fstat(fileno(fp), &stat_buf);
+@@ -36,13 +36,13 @@
+
+ if (memcmp(datap, PM9SCREW, PM9SCREW_LEN) == 0) {
+ fprintf(stderr, "Already Crypted(%s)\n", argv[1]);
+- exit();
++ exit(1);
+ }
+
+ fp = fopen(oldfilename, "w");
+ if (fp == NULL) {
+ fprintf(stderr, "Can not create backup file(%s)\n", oldfilename);
+- exit();
++ exit(1);
+ }
+ fwrite(datap, datalen, 1, fp);
+ fclose(fp);
+@@ -56,7 +56,7 @@
+ fp = fopen(argv[1], "w");
+ if (fp == NULL) {
+ fprintf(stderr, "Can not create crypt file(%s)\n", oldfilename);
+- exit();
++ exit(1);
+ }
+ fwrite(PM9SCREW, PM9SCREW_LEN, 1, fp);
+ fwrite(newdatap, newdatalen, 1, fp);