aboutsummaryrefslogtreecommitdiff
path: root/www/php-templates
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-02-28 16:34:21 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-02-28 16:34:21 +0000
commit2d831557079c2119fca773762733bac366b742c5 (patch)
tree777554db3110628ab7d43b0d7d50f4afe1e0bbce /www/php-templates
parentc34230526d53879966c6bf31f8c5edd9c62a1c74 (diff)
downloadports-2d831557079c2119fca773762733bac366b742c5.tar.gz
ports-2d831557079c2119fca773762733bac366b742c5.zip
Notes
Diffstat (limited to 'www/php-templates')
-rw-r--r--www/php-templates/Makefile42
-rw-r--r--www/php-templates/distinfo1
-rw-r--r--www/php-templates/pkg-comment1
-rw-r--r--www/php-templates/pkg-descr1
-rw-r--r--www/php-templates/pkg-message6
-rw-r--r--www/php-templates/pkg-plist1
6 files changed, 52 insertions, 0 deletions
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
new file mode 100644
index 000000000000..bb609ad99635
--- /dev/null
+++ b/www/php-templates/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: php_templates
+# Date created: Feb 28 2002
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-templates
+PORTVERSION= 0.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= php_templates-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake \
+ autoconf:${PORTSDIR}/devel/autoconf \
+ phpize:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13 \
+ ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+USE_LIBTOOL= yes
+LIBTOOLFILES= aclocal.m4
+
+WRKSRC= ${WRKDIR}/templates
+
+CONFIGURE_ARGS+=--enable-templates=shared \
+ --with-php-config=${PREFIX}/bin/php-config
+
+post-extract:
+ @${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
+
+do-install:
+ @${INSTALL} ${WRKSRC}/modules/templates.so \
+ ${LOCALBASE}/lib/php/20010901
+
+post-install:
+ @${SED} s!%%LOCALBASE%%!${LOCALBASE}!g ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/php-templates/distinfo b/www/php-templates/distinfo
new file mode 100644
index 000000000000..2ccffbc7e274
--- /dev/null
+++ b/www/php-templates/distinfo
@@ -0,0 +1 @@
+MD5 (php_templates-0.2.tar.gz) = 1f18df4b54e5f541afaad31f9c3225cc
diff --git a/www/php-templates/pkg-comment b/www/php-templates/pkg-comment
new file mode 100644
index 000000000000..d84b35c1702c
--- /dev/null
+++ b/www/php-templates/pkg-comment
@@ -0,0 +1 @@
+A template framework for PHP
diff --git a/www/php-templates/pkg-descr b/www/php-templates/pkg-descr
new file mode 100644
index 000000000000..d84b35c1702c
--- /dev/null
+++ b/www/php-templates/pkg-descr
@@ -0,0 +1 @@
+A template framework for PHP
diff --git a/www/php-templates/pkg-message b/www/php-templates/pkg-message
new file mode 100644
index 000000000000..79bc88bb1684
--- /dev/null
+++ b/www/php-templates/pkg-message
@@ -0,0 +1,6 @@
+
+You have installed the php-templates package.
+
+Edit %%LOCALBASE%%/etc/php.ini and add:
+
+extension="%%LOCALBASE%%/lib/php/20010901/templates.so"
diff --git a/www/php-templates/pkg-plist b/www/php-templates/pkg-plist
new file mode 100644
index 000000000000..ec8b94a9c299
--- /dev/null
+++ b/www/php-templates/pkg-plist
@@ -0,0 +1 @@
+lib/php/20010901/templates.so