aboutsummaryrefslogtreecommitdiff
path: root/www/phpbb/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-14 15:17:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-14 15:17:44 +0000
commit55571c1c5d9c65cdefe629e9e0865ca42508b6d9 (patch)
treea8533b1076b916acb53e57686176c17c83274bd0 /www/phpbb/Makefile
parentd3a3d3c66db404cf90030c7e2d1ee3cb886251ba (diff)
downloadports-55571c1c5d9c65cdefe629e9e0865ca42508b6d9.tar.gz
ports-55571c1c5d9c65cdefe629e9e0865ca42508b6d9.zip
Notes
Diffstat (limited to 'www/phpbb/Makefile')
-rw-r--r--www/phpbb/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/phpbb/Makefile b/www/phpbb/Makefile
index 279fc1018614..4417796d71f8 100644
--- a/www/phpbb/Makefile
+++ b/www/phpbb/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= phpbb
-PORTVERSION= 2.0.8
-PORTREVISION= 3
+PORTVERSION= 2.0.9
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= phpBB-${PORTVERSION}a
+DISTNAME= phpBB-${PORTVERSION}
-MAINTAINER= liukang@bjpu.edu.cn
+MAINTAINER= liukang@bjut.edu.cn
COMMENT= A PHP-based bulletin board / discussion forum system
RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:${PORTSDIR}/devel/pear-PEAR
@@ -37,6 +36,7 @@ NO_BUILD= yes
USE_REINPLACE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB+= PHPBBDIR=${PHPBBDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+PLIST_SUB+= PHPBB_VER=${PORTVERSION:S/.//g}
# Set custom variables:
#
@@ -61,6 +61,7 @@ pre-everything::
post-patch:
@ ${REINPLACE_CMD} -e "s#\.\./templates#/${PHPBBURL}/templates#" \
${WRKSRC}/docs/*.html
+ @${RM} -f `${FIND} ${WRKSRC} -name '*.orig'`
post-configure:
@ ${SED} \