aboutsummaryrefslogtreecommitdiff
path: root/www/phpbb
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 08:32:03 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 08:32:03 +0000
commit2bebbc676d7f2efefba8b088bda6b2fbadf90de3 (patch)
tree580570b8e6aff24bbd34081a2f83e8c3843fdbdf /www/phpbb
parent93b3ce47c7df8fa680714bcefd86ff5e284ece6b (diff)
downloadports-2bebbc676d7f2efefba8b088bda6b2fbadf90de3.tar.gz
ports-2bebbc676d7f2efefba8b088bda6b2fbadf90de3.zip
Notes
Diffstat (limited to 'www/phpbb')
-rw-r--r--www/phpbb/Makefile15
-rw-r--r--www/phpbb/distinfo4
-rw-r--r--www/phpbb/files/patch-includes-sessions.php12
-rw-r--r--www/phpbb/files/patch-includes-usercp_register.php16
-rw-r--r--www/phpbb/files/pkg-message.in (renamed from www/phpbb/pkg-message)0
-rw-r--r--www/phpbb/pkg-plist1
6 files changed, 13 insertions, 35 deletions
diff --git a/www/phpbb/Makefile b/www/phpbb/Makefile
index 455f520a8de4..d1a2518b2a9c 100644
--- a/www/phpbb/Makefile
+++ b/www/phpbb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= phpbb
-PORTVERSION= 2.0.13
-PORTREVISION= 1
+PORTVERSION= 2.0.15
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -35,7 +34,10 @@ WWWGRP?= www
WRKSRC= ${WRKDIR}/phpBB2
NO_BUILD= yes
USE_REINPLACE= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= PHPBBURL="${PHPBBURL}" \
+ PHPBBDIR="${PHPBBDIR}" \
+ DELETEFILES="${EXCEPTFILES}"
PHPBB_VER= ${PORTVERSION:S/.//g:S/.//g}
PLIST_SUB+= PHPBBDIR=${PHPBBDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
PLIST_SUB+= PHPBB_VER=${PHPBB_VER}
@@ -65,13 +67,6 @@ post-patch:
${WRKSRC}/docs/*.html
@${RM} -f `${FIND} ${WRKSRC} -name '*.orig'`
-post-configure:
- @ ${SED} \
- -e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%DOCSDIR%%#${DOCSDIR}#g' \
- -e 's#%%PHPBBURL%%#${PHPBBURL}#g' -e 's#%%PHPBBDIR%%#${PHPBBDIR}#g' \
- -e 's#%%DATADIR%%#${DATADIR}#g' \
- -e 's#%%DELETEFILES%%#${EXCEPTFILES}#g' pkg-message > ${PKGMESSAGE}
-
do-install:
@ ${MKDIR} -m 0775 ${PREFIX}/${PHPBBDIR}
@ cd ${WRKSRC} && ${FIND} * \( -name config.php \
diff --git a/www/phpbb/distinfo b/www/phpbb/distinfo
index e63041d06977..11f997319d28 100644
--- a/www/phpbb/distinfo
+++ b/www/phpbb/distinfo
@@ -1,2 +1,2 @@
-MD5 (phpBB-2.0.13.tar.bz2) = a8a286d3855b969e1e8757464accf095
-SIZE (phpBB-2.0.13.tar.bz2) = 436886
+MD5 (phpBB-2.0.15.tar.bz2) = 864c7dbd8d2cf402f86d9b87e07be266
+SIZE (phpBB-2.0.15.tar.bz2) = 443803
diff --git a/www/phpbb/files/patch-includes-sessions.php b/www/phpbb/files/patch-includes-sessions.php
index 697a1241c6ae..bb15b73c06a1 100644
--- a/www/phpbb/files/patch-includes-sessions.php
+++ b/www/phpbb/files/patch-includes-sessions.php
@@ -1,15 +1,15 @@
---- includes/sessions.php.orig Sun Jul 20 17:42:23 2003
-+++ includes/sessions.php Thu May 6 12:02:56 2004
-@@ -147,7 +147,7 @@
+--- includes/sessions.php.orig Sat May 14 05:04:00 2005
++++ includes/sessions.php Sun May 15 18:53:48 2005
+@@ -167,7 +167,7 @@
$sql = "INSERT INTO " . SESSIONS_TABLE . "
- (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in)
- VALUES ('$session_id', $user_id, $current_time, $current_time, '$user_ip', $page_id, $login)";
+ (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in, session_admin)
+ VALUES ('$session_id', $user_id, $current_time, $current_time, '$user_ip', $page_id, $login, $admin)";
- if ( !$db->sql_query($sql) )
+ if ( $user_id != ANONYMOUS && !$db->sql_query($sql) )
{
message_die(CRITICAL_ERROR, 'Error creating new session', '', __LINE__, __FILE__, $sql);
}
-@@ -380,4 +380,4 @@
+@@ -421,4 +421,4 @@
return $url;
}
diff --git a/www/phpbb/files/patch-includes-usercp_register.php b/www/phpbb/files/patch-includes-usercp_register.php
deleted file mode 100644
index cbd39c827557..000000000000
--- a/www/phpbb/files/patch-includes-usercp_register.php
+++ /dev/null
@@ -1,16 +0,0 @@
---- includes/usercp_register.php.orig Sun Mar 13 19:44:02 2005
-+++ includes/usercp_register.php Sun Mar 13 19:48:34 2005
-@@ -145,10 +145,9 @@
- if ( $mode == 'register' )
- {
- $attachsig = ( isset($HTTP_POST_VARS['attachsig']) ) ? ( ($HTTP_POST_VARS['attachsig']) ? TRUE : 0 ) : $board_config['allow_sig'];
--
-- $allowhtml = ( isset($HTTP_POST_VARS['allowhtml']) ) ? ( ($HTTP_POST_VARS['allowhtml']) ? TRUE : 0 ) : $board_config['allow_html'];
-- $allowbbcode = ( isset($HTTP_POST_VARS['allowbbcode']) ) ? ( ($HTTP_POST_VARS['allowbbcode']) ? TRUE : 0 ) : $board_config['allow_bbcode'];
-- $allowsmilies = ( isset($HTTP_POST_VARS['allowsmilies']) ) ? ( ($HTTP_POST_VARS['allowsmilies']) ? TRUE : 0 ) : $board_config['allow_smilies'];
-+ $allowhtml = ( ($board_config['allowhtml']) ) ? TRUE : 0;
-+ $allowbbcode = ( ($board_config['allowbbcode']) ) ? TRUE : 0;
-+ $allowsmilies = ( ($board_config['allowsmilies']) ) ? TRUE : 0;
- }
- else
- {
diff --git a/www/phpbb/pkg-message b/www/phpbb/files/pkg-message.in
index d8de0457cca9..d8de0457cca9 100644
--- a/www/phpbb/pkg-message
+++ b/www/phpbb/files/pkg-message.in
diff --git a/www/phpbb/pkg-plist b/www/phpbb/pkg-plist
index b808cbc29771..f8e4aa1bbc01 100644
--- a/www/phpbb/pkg-plist
+++ b/www/phpbb/pkg-plist
@@ -43,7 +43,6 @@
%%PHPBBDIR%%/db/mssql.php
%%PHPBBDIR%%/db/mysql.php
%%PHPBBDIR%%/db/mysql4.php
-%%PHPBBDIR%%/db/oracle.php
%%PHPBBDIR%%/db/postgres7.php
%%PHPBBDIR%%/extension.inc
%%PHPBBDIR%%/faq.php