aboutsummaryrefslogtreecommitdiff
path: root/www/phpmp
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-10-05 09:29:40 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-10-05 09:29:40 +0000
commitd6f6f0f6dff43e8cbd628f246fcbc29499de6175 (patch)
treeeca39b28902963f4e4bb6a606599b75c379ce5af /www/phpmp
parentf6d1de7243952cc0ec1eb944c7be606bd0054864 (diff)
downloadports-d6f6f0f6dff43e8cbd628f246fcbc29499de6175.tar.gz
ports-d6f6f0f6dff43e8cbd628f246fcbc29499de6175.zip
Notes
Diffstat (limited to 'www/phpmp')
-rw-r--r--www/phpmp/Makefile7
-rw-r--r--www/phpmp/pkg-plist10
2 files changed, 8 insertions, 9 deletions
diff --git a/www/phpmp/Makefile b/www/phpmp/Makefile
index b4b4d3cea53a..aeea0c33d0d7 100644
--- a/www/phpmp/Makefile
+++ b/www/phpmp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phpmp
PORTVERSION= 0.12.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/
@@ -15,15 +16,11 @@ NO_BUILD= yes
USE_PHP= pcre sockets
PHPMP?= ${WWWDIR_REL}
-PLIST_SUB+= PHPMP=${PHPMP}
+PLIST_SUB= PHPMP="${PHPMP}" WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${PHPMP}
@${CP} -R ${WRKSRC}/ ${STAGEDIR}${PREFIX}/${PHPMP}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${PREFIX}/${PHPMP}
@${CHMOD} -R 755 ${STAGEDIR}${PREFIX}/${PHPMP}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/www/phpmp/pkg-plist b/www/phpmp/pkg-plist
index 94ba08bf83cb..3d83d702b070 100644
--- a/www/phpmp/pkg-plist
+++ b/www/phpmp/pkg-plist
@@ -1,11 +1,11 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%PHPMP%%/COPYING
%%PHPMP%%/ChangeLog
%%PHPMP%%/INSTALL
%%PHPMP%%/README
%%PHPMP%%/TODO
-@unexec if cmp -s %D/%%PHPMP%%/config.php.sample %D/%%PHPMP%%/config.php; then rm -f %D/%%PHPMP%%/config.php; fi
-%%PHPMP%%/config.php.sample
-@exec if [ ! -f %D/%%PHPMP%%/config.php ] ; then cp -p %D/%F %B/config.php; fi
+@sample %%PHPMP%%/config.php.sample
%%PHPMP%%/features.php
%%PHPMP%%/index.php
%%PHPMP%%/info.php
@@ -18,4 +18,6 @@
%%PHPMP%%/transparent.gif
%%PHPMP%%/utils.php
%%PHPMP%%/xml-parse.php
-@dirrmtry %%PHPMP%%
+@dir %%PHPMP%%
+@owner
+@group