aboutsummaryrefslogtreecommitdiff
path: root/www/phpmustache
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-06 14:41:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-06 14:41:49 +0000
commit5490c01a81d26107ef56316d4e35e16703ae563e (patch)
treed5531cb5b302347a3627702c0e819d83abbd4a05 /www/phpmustache
parent1ff79b1d09447483e2b27b50e30066373e4214dc (diff)
downloadports-5490c01a81d26107ef56316d4e35e16703ae563e.tar.gz
ports-5490c01a81d26107ef56316d4e35e16703ae563e.zip
Notes
Diffstat (limited to 'www/phpmustache')
-rw-r--r--www/phpmustache/Makefile51
-rw-r--r--www/phpmustache/distinfo2
-rw-r--r--www/phpmustache/files/pkg-message.in4
-rw-r--r--www/phpmustache/pkg-descr3
-rw-r--r--www/phpmustache/pkg-plist136
5 files changed, 196 insertions, 0 deletions
diff --git a/www/phpmustache/Makefile b/www/phpmustache/Makefile
new file mode 100644
index 000000000000..23494aa691b3
--- /dev/null
+++ b/www/phpmustache/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: phpmustache
+# Date created: 25 October 2011
+# Whom: Steve Polyack <spolyack@collaborativefusion.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmustache
+PORTVERSION= 0.8.1
+CATEGORIES= www
+MASTER_SITES= https://github.com/bobthecow/mustache.php/tarball/master/
+DISTNAME= bobthecow-mustache.php-v${PORTVERSION}-0-g${GITVERSION}
+
+MAINTAINER= spolyack@collaborativefusion.com
+COMMENT= PHP5 code for Mustache
+
+GITVERSION= 1e23df0
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/bobthecow-mustache.php-${GITVERSION}
+
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/Mustache.php ${DATADIR}
+ @${MKDIR} ${DATADIR}/test
+ @${INSTALL_DATA} ${WRKSRC}/test/*.php ${WRKSRC}/test/phpunit.xml ${DATADIR}/test
+ @${MKDIR} ${DATADIR}/test/lib/yaml/doc ${DATADIR}/test/lib/yaml/lib
+.for f in README.markdown LICENSE package.xml
+ @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/$f ${DATADIR}/test/lib/yaml
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/lib/* ${DATADIR}/test/lib/yaml/lib
+ @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/doc/* ${DATADIR}/test/lib/yaml/doc
+ @${MKDIR} ${DATADIR}/test/spec
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in README.markdown LICENSE
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/phpmustache/distinfo b/www/phpmustache/distinfo
new file mode 100644
index 000000000000..430c7f25abca
--- /dev/null
+++ b/www/phpmustache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bobthecow-mustache.php-v0.8.1-0-g1e23df0.tar.gz) = 9111025ef0fa8b1412436ee26fc8715726399da16c57a69e29fb4927c42ede1c
+SIZE (bobthecow-mustache.php-v0.8.1-0-g1e23df0.tar.gz) = 41364
diff --git a/www/phpmustache/files/pkg-message.in b/www/phpmustache/files/pkg-message.in
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/www/phpmustache/files/pkg-message.in
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/www/phpmustache/pkg-descr b/www/phpmustache/pkg-descr
new file mode 100644
index 000000000000..a906e0ac0a0d
--- /dev/null
+++ b/www/phpmustache/pkg-descr
@@ -0,0 +1,3 @@
+A Mustache implementation in PHP.
+
+WWW: https://github.com/bobthecow/mustache.php
diff --git a/www/phpmustache/pkg-plist b/www/phpmustache/pkg-plist
new file mode 100644
index 000000000000..f93aa6c57d32
--- /dev/null
+++ b/www/phpmustache/pkg-plist
@@ -0,0 +1,136 @@
+%%DATADIR%%/Mustache.php
+%%PORTDOCS%%%%DOCSDIR%%/README.markdown
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/ChildContext.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comments/Comments.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comments/comments.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comments/comments.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/complex/complex.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/complex/complex.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/complex/complex.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/delimiters/Delimiters.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/delimiters/delimiters.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/delimiters/delimiters.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot_notation/DotNotation.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot_notation/dot_notation.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot_notation/dot_notation.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/double_section/DoubleSection.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/double_section/double_section.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/double_section/double_section.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/escaped/Escaped.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/escaped/escaped.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/escaped/escaped.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/GrandParentContext.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/grand_parent_context.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/grand_parent_context.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/ImplicitIterator.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/implicit_iterator.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/implicit_iterator.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_double_section/InvertedDoubleSection.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_double_section/inverted_double_section.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_double_section/inverted_double_section.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/InvertedSection.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/Partials.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/PartialsWithViewClass.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/partials_with_view_class.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/partials_with_view_class.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/PragmaUnescaped.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/pragma_unescaped.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/pragma_unescaped.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/PragmasInPartials.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/pragmas_in_partials.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/pragmas_in_partials.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/RecursivePartials.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_iterator_objects/SectionIteratorObjects.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_iterator_objects/section_iterator_objects.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_iterator_objects/section_iterator_objects.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_magic_objects/SectionMagicObjects.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_magic_objects/section_magic_objects.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_magic_objects/section_magic_objects.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_objects/SectionObjects.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_objects/section_objects.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_objects/section_objects.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections/Sections.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections/sections.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections/sections.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections_nested/SectionsNested.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections_nested/sections_nested.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sections_nested/sections_nested.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/Simple.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/simple.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple/simple.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unescaped/Unescaped.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unescaped/unescaped.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unescaped/unescaped.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8/UTF8.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8/utf8.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8/utf8.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/UTF8Unescaped.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/Whitespace.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.txt
+%%DATADIR%%/test/MustacheExceptionTest.php
+%%DATADIR%%/test/MustacheHigherOrderSectionsTest.php
+%%DATADIR%%/test/MustacheInjectionTest.php
+%%DATADIR%%/test/MustacheObjectSectionTest.php
+%%DATADIR%%/test/MustachePragmaTest.php
+%%DATADIR%%/test/MustachePragmaUnescapedTest.php
+%%DATADIR%%/test/MustacheSpecTest.php
+%%DATADIR%%/test/MustacheTest.php
+%%DATADIR%%/test/lib/yaml/LICENSE
+%%DATADIR%%/test/lib/yaml/README.markdown
+%%DATADIR%%/test/lib/yaml/doc/00-Introduction.markdown
+%%DATADIR%%/test/lib/yaml/doc/01-Usage.markdown
+%%DATADIR%%/test/lib/yaml/doc/02-YAML.markdown
+%%DATADIR%%/test/lib/yaml/doc/A-License.markdown
+%%DATADIR%%/test/lib/yaml/lib/sfYaml.php
+%%DATADIR%%/test/lib/yaml/lib/sfYamlDumper.php
+%%DATADIR%%/test/lib/yaml/lib/sfYamlInline.php
+%%DATADIR%%/test/lib/yaml/lib/sfYamlParser.php
+%%DATADIR%%/test/lib/yaml/package.xml
+%%DATADIR%%/test/phpunit.xml
+@dirrm %%DATADIR%%/test/lib/yaml/doc
+@dirrm %%DATADIR%%/test/lib/yaml/lib
+@dirrm %%DATADIR%%/test/lib/yaml
+@dirrm %%DATADIR%%/test/lib
+@dirrm %%DATADIR%%/test/spec
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/child_context
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/comments
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/complex
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/delimiters
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/dot_notation
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/double_section
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/escaped
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/grand_parent_context
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/implicit_iterator
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_double_section
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_section
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials_with_view_class
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pragma_unescaped
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pragmas_in_partials
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/recursive_partials
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_iterator_objects
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_magic_objects
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_objects
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sections
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sections_nested
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/simple
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/unescaped
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8_unescaped
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/whitespace
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%