aboutsummaryrefslogtreecommitdiff
path: root/www/phpwiki13/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-03-06 06:54:19 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-03-06 06:54:19 +0000
commitbe4c6448a890a12891a93bbc158a66ec4e868e79 (patch)
tree8cbaf74b97ffda20f53930215deea45720b020a0 /www/phpwiki13/Makefile
parent153a5ec176dc0b1a86f0eddd7cfb0ee8009b6c1f (diff)
downloadports-be4c6448a890a12891a93bbc158a66ec4e868e79.tar.gz
ports-be4c6448a890a12891a93bbc158a66ec4e868e79.zip
Notes
Diffstat (limited to 'www/phpwiki13/Makefile')
-rw-r--r--www/phpwiki13/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/www/phpwiki13/Makefile b/www/phpwiki13/Makefile
index 0ab2aaab774d..a0882ec51fa7 100644
--- a/www/phpwiki13/Makefile
+++ b/www/phpwiki13/Makefile
@@ -32,23 +32,10 @@ DOCFILES= INSTALL LICENSE README TODO UPGRADING
OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off \
- DB4 "Use Berkeley DB4 backend" off
+ DB4 "Use Berkeley DB4 backend" off \
+ SQLITE "Use SQLite backend (php5 only)" off
-.if exists(${LOCALBASE}/etc/php.conf)
-.include "${LOCALBASE}/etc/php.conf"
-.endif
-
-.if defined(PHP_VER) && ${PHP_VER} == 5
-OPTIONS+= SQLITE "Use SQLite backend" off
-.endif
-
-PORT_DBDIR?= /var/db/ports
-LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
-
-.if exists(${OPTIONSFILE})
-.include "${OPTIONSFILE}"
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_DB4)
USE_PHP+= dba
@@ -84,4 +71,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>