aboutsummaryrefslogtreecommitdiff
path: root/www/plone
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-04-25 11:09:34 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-04-25 11:09:34 +0000
commitee04a921c5b762e87d76a22464388f5a19a112d6 (patch)
tree4cfe6553aa16f8829e9a1bad5fc6d308e5f8e168 /www/plone
parent881b44a3a070c17a27848f4e1a1fdd9ec4be5e3a (diff)
downloadports-ee04a921c5b762e87d76a22464388f5a19a112d6.tar.gz
ports-ee04a921c5b762e87d76a22464388f5a19a112d6.zip
Notes
Diffstat (limited to 'www/plone')
-rw-r--r--www/plone/Makefile33
-rw-r--r--www/plone/distinfo2
-rw-r--r--www/plone/pkg-descr12
-rw-r--r--www/plone/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/www/plone/Makefile b/www/plone/Makefile
new file mode 100644
index 000000000000..0ebb4ab6aa50
--- /dev/null
+++ b/www/plone/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: plone
+# Date created: 25 April 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone
+PORTVERSION= 4.1.5
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+DISTNAME= Plone-${PORTVERSION}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= The Plone Content Management System
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Products.CMFPlacefulWorkflow>=0:${PORTSDIR}/devel/py-Products.CMFPlacefulWorkflow \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFPlone>=0:${PORTSDIR}/www/py-Products.CMFPlone \
+ ${PYTHON_PKGNAMEPREFIX}Products.kupu>=0:${PORTSDIR}/www/py-Products.kupu \
+ ${PYTHON_PKGNAMEPREFIX}plone.app.caching>=0:${PORTSDIR}/www/py-plone.app.caching \
+ ${PYTHON_PKGNAMEPREFIX}plone.app.iterate>=0:${PORTSDIR}/www/py-plone.app.iterate \
+ ${PYTHON_PKGNAMEPREFIX}plone.app.openid>=0:${PORTSDIR}/security/py-plone.app.openid \
+ ${PYTHON_PKGNAMEPREFIX}wicked>=0:${PORTSDIR}/textproc/py-wicked
+
+DIST_SUBDIR= zope
+PYDISTUTILS_PKGNAME= Plone
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+
+.include <bsd.port.mk>
diff --git a/www/plone/distinfo b/www/plone/distinfo
new file mode 100644
index 000000000000..2be1b4350c00
--- /dev/null
+++ b/www/plone/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope/Plone-4.1.5.zip) = 4b735498fc89ebbed0cfdc14ae24a853ef7111150bdfe3fe38c6c7fbb4ea73f3
+SIZE (zope/Plone-4.1.5.zip) = 20801
diff --git a/www/plone/pkg-descr b/www/plone/pkg-descr
new file mode 100644
index 000000000000..c1eaf3d83af6
--- /dev/null
+++ b/www/plone/pkg-descr
@@ -0,0 +1,12 @@
+Plone is a user friendly Content Management System running on top of Python,
+Zope and the CMF.
+It benefits from all features of Zope/CMF such as: RDBMS integration, Python
+extensions, Object Oriented Database, Web configurable workflow, pluggable
+membership and authentication, Undos, Form validation, amongst many many other
+features. Available protocols: FTP, XMLRPC, HTTP and WEBDAV.
+Turn it into a distributed application system by installing ZEO.
+
+Plone shares some of the qualities of Livelink, Interwoven and Documentum. It
+aims to be *the* open source out-of-the-box publishing system.
+
+WWW: http://plone.org/
diff --git a/www/plone/pkg-plist b/www/plone/pkg-plist
new file mode 100644
index 000000000000..c46ab112b024
--- /dev/null
+++ b/www/plone/pkg-plist
@@ -0,0 +1,8 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%