aboutsummaryrefslogtreecommitdiff
path: root/www/podcastamatic/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:17:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:17:14 +0000
commitfb1d43db730f569de5e196ae00ebc47221dd5b1c (patch)
tree66e36492bd94458e07ed1bd468eaaf11717cd92b /www/podcastamatic/Makefile
parent073c6a731e40dea844d4723ebfcc7d14dd1cb97c (diff)
downloadports-fb1d43db730f569de5e196ae00ebc47221dd5b1c.tar.gz
ports-fb1d43db730f569de5e196ae00ebc47221dd5b1c.zip
Notes
Diffstat (limited to 'www/podcastamatic/Makefile')
-rw-r--r--www/podcastamatic/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/www/podcastamatic/Makefile b/www/podcastamatic/Makefile
new file mode 100644
index 000000000000..9dea6827f69d
--- /dev/null
+++ b/www/podcastamatic/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: podcastamatic
+# Date created: 12 July 2005
+# Whom: lars.eggert@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= podcastamatic
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://bradley.chicago.il.us/projects/podcastamatic/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Automates creation of webpage and RSS feed for a podcast
+
+RUN_DEPENDS= ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+
+USE_ZIP= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+do-patch:
+ @${REINPLACE_CMD} -e "s|${PORTNAME}.conf|${PREFIX}/etc/${PORTNAME}.conf|"\
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/style.css ${PREFIX}/share/${PORTNAME}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.html ${DOCSDIR}
+.endif
+ @${ECHO}
+ @${ECHO} "Edit ${PREFIX}/etc/${PORTNAME}.conf"
+ @${ECHO} "CSS in ${PREFIX}/share/${PORTNAME}/style.css"
+ @${ECHO}
+
+.include <bsd.port.mk>