aboutsummaryrefslogtreecommitdiff
path: root/www/pound
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2010-03-23 21:38:01 +0000
committerAnders Nordby <anders@FreeBSD.org>2010-03-23 21:38:01 +0000
commit028f86ef47c28c6de58e4db9163931f79107dd00 (patch)
treebca2c4ffd1b72b772e04f02c2a77386dcda4d64c /www/pound
parentdeb82389ebc5b4e7b2e00266af6df83138fda4b3 (diff)
downloadports-028f86ef47c28c6de58e4db9163931f79107dd00.tar.gz
ports-028f86ef47c28c6de58e4db9163931f79107dd00.zip
Notes
Diffstat (limited to 'www/pound')
-rw-r--r--www/pound/Makefile44
-rw-r--r--www/pound/distinfo6
-rw-r--r--www/pound/files/patch-Makefile.in11
-rw-r--r--www/pound/pkg-plist2
4 files changed, 26 insertions, 37 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 07ca78aaf5a3..248dba3000b3 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 2.4.5
+PORTVERSION= 2.5
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -22,50 +22,30 @@ USE_RC_SUBR= ${PORTNAME}.sh
SUB_LIST= NAME=${PORTNAME}
-POUND_CFLAGS= ${CFLAGS}
-POUND_LDFLAGS= ${LDFLAGS}
-MAKE_ARGS+= F_CONF=${PREFIX}/etc/pound.cfg
-
MAN8= pound.8 poundctl.8
-OPTIONS= DAEMON "Running as a daemon" on \
- LIBTHR "Link against libthr for threading" on \
- LOG "With Syslog support" on \
- MSDAV "With the Microsoft WebDAV extensions support" off \
- PCRE "Build with libpcre support" off
-
-.include <bsd.port.pre.mk>
+OPTIONS= MSDAV "With the Microsoft WebDAV extensions support" off \
+ PCRE "Build with libpcre support" on
+CONFIGURE_ARGS= --disable--tcmalloc --disable-hoard
+PLIST_FILES= sbin/pound sbin/poundctl
PORTDOCS= README FAQ CHANGELOG
-.if defined(WITHOUT_DAEMON)
-CONFIGURE_ARGS+= --disable-daemon
-.endif
-
-.if defined(WITHOUT_LOG)
-CONFIGURE_ARGS+= --disable-log
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_MSDAV)
CONFIGURE_ARGS+= --enable-msdav
.endif
-.if defined(WITH_PCRE)
+.if !defined(WITHOUT_PCRE)
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-POUND_CFLAGS+= "-I${LOCALBASE}/include"
-POUND_LDFLAGS+= "-L${LOCALBASE}/lib"
+CFLAGS+= "-I${LOCALBASE}/include"
+CPPFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= "-L${LOCALBASE}/lib"
+.else
+CONFIGURE_ARGS+= --disable-pcreposix
.endif
-.if !defined(WITHOUT_LIBTHR)
-PTHREAD_LIBS= -lthr
-.endif
-
-CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- CFLAGS="${POUND_CFLAGS}" \
- CPPFLAGS="${POUND_CFLAGS}" \
- LDFLAGS="${POUND_LDFLAGS}"
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/www/pound/distinfo b/www/pound/distinfo
index aeb5417c00b4..40f25888964b 100644
--- a/www/pound/distinfo
+++ b/www/pound/distinfo
@@ -1,3 +1,3 @@
-MD5 (Pound-2.4.5.tgz) = 4c4613e857ee14c06c61ab09e28ae503
-SHA256 (Pound-2.4.5.tgz) = f7d595e08bbb7733434d154f7ced289a38214966734680b9e61de10307c528d9
-SIZE (Pound-2.4.5.tgz) = 170486
+MD5 (Pound-2.5.tgz) = 8a39f5902094619afcda7d12d9d8342c
+SHA256 (Pound-2.5.tgz) = 11dfa7b469636d43aec803455894b30821ba7f6641c1cfd45df53059d3ac4c95
+SIZE (Pound-2.5.tgz) = 172084
diff --git a/www/pound/files/patch-Makefile.in b/www/pound/files/patch-Makefile.in
new file mode 100644
index 000000000000..9139c62a3512
--- /dev/null
+++ b/www/pound/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2010-02-02 13:08:09.689620453 +0100
++++ Makefile.in 2010-02-02 13:08:15.287921870 +0100
+@@ -63,7 +63,7 @@
+ $(OBJS): pound.h config.h
+
+ svc.o: svc.c dh512.h dh1024.h
+- gcc ${CFLAGS} -c -o svc.o svc.c
++ ${CC} ${CFLAGS} -c -o svc.o svc.c
+
+ install: all
+ @INSTALL@ -d ${DESTDIR}@sbindir@
diff --git a/www/pound/pkg-plist b/www/pound/pkg-plist
deleted file mode 100644
index 33a9249d215f..000000000000
--- a/www/pound/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-sbin/pound
-sbin/poundctl