aboutsummaryrefslogtreecommitdiff
path: root/www/privoxy+ipv6/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-15 10:01:26 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-15 10:01:26 +0000
commite017a80a0e9f4ebd0267b77e0811964c822cdd15 (patch)
tree5d43b851ae9e6a273918df0fc2bfc30cf550c500 /www/privoxy+ipv6/Makefile
parent3c9ecc4516917c2fb49723612d44fae8b362d752 (diff)
downloadports-e017a80a0e9f4ebd0267b77e0811964c822cdd15.tar.gz
ports-e017a80a0e9f4ebd0267b77e0811964c822cdd15.zip
Notes
Diffstat (limited to 'www/privoxy+ipv6/Makefile')
-rw-r--r--www/privoxy+ipv6/Makefile72
1 files changed, 28 insertions, 44 deletions
diff --git a/www/privoxy+ipv6/Makefile b/www/privoxy+ipv6/Makefile
index f27630f1128b..e22b50696c2e 100644
--- a/www/privoxy+ipv6/Makefile
+++ b/www/privoxy+ipv6/Makefile
@@ -1,63 +1,47 @@
-# New ports collection makefile for: privoxy
-# Date created: 21 November 2002
-# Whom: John von Essen
+# New ports collection makefile for: privoxy+ipv6
+# Date created: 17 June 2003
+# Whom: Lars Eggert
#
# $FreeBSD$
#
-PORTNAME= privoxy
-PORTVERSION= 3.0.0
-CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ijbswa
-DISTNAME= privoxy-3.0.0-stable-src
+PORTNAME= privoxy+ipv6
+PORTVERSION= 20030523
+CATEGORIES= www ipv6
+MASTER_SITES= ftp://ftp.deepspace6.net/pub/sources/privoxy/
+DISTNAME= privoxy_CVS_${PORTVERSION}_ipv6_5
-MAINTAINER= john@essenz.com
+MAINTAINER= larse@isi.edu
COMMENT= Privoxy is a web proxy with advanced filtering capabilities
-WRKSRC= ${WRKDIR}/privoxy-3.0.0-stable
+WRKSRC= ${WRKDIR}/privoxy
-PKGMESSAGE= ${WRKDIR}/pkg-message
+ETCDIR= ${PREFIX}/etc/privoxy
+USER= nobody
+GROUP= nobody
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+ipv6//}
+USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
+USE_AUTOCONF= yes
USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-user=${USER} --with-group=${GROUP} \
+ --sysconfdir=${ETCDIR} --localstatedir=/var
+
MAKEFILE= GNUmakefile
MAN1= privoxy.1
-post-patch:
- ${REINPLACE_CMD} \
- -e 's,^\(confdir\) \.,\1 ${PREFIX}/etc/privoxy,' \
- -e 's,^\(logdir\) \.,\1 /tmp,' \
- -e 's,^\(actionsfile standard\),#\1,' \
- -e 's,^\(actionsfile user\),#\1,' \
- ${WRKSRC}/config
-
-pre-configure:
- @cd ${WRKSRC}; ${AUTOHEADER}
-
-pre-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- ${PKGDIR}/pkg-message.in > ${PKGMESSAGE}
-
-do-install:
- @${MKDIR} ${PREFIX}/etc/privoxy/templates
- @${INSTALL_PROGRAM} ${WRKSRC}/privoxy ${PREFIX}/sbin
- @${INSTALL_DATA} ${WRKSRC}/templates/[a-z]* ${PREFIX}/etc/privoxy/templates
-.for file in config default.action default.filter trust
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/etc/privoxy
-.endfor
- @${INSTALL_MAN} ${WRKSRC}/privoxy.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/privoxy-manual
- @if [ -d ${WRKSRC}/doc/webserver/user-manual ]; then \
- ${INSTALL_DATA} ${WRKSRC}/doc/webserver/user-manual/[a-z]* ${PREFIX}/share/doc/privoxy-manual; \
- fi
-.endif
-
post-install:
- @${CAT} ${PKGMESSAGE}
+ @for file in config user.action; do \
+ if [ ! -f ${ETCDIR}/$$file ]; then \
+ ${CP} ${ETCDIR}/$$file.sample ${ETCDIR}/$$file; \
+ ${CHOWN} ${USER}:${GROUP} ${ETCDIR}/$$file; \
+ ${CHMOD} ug+rw ${ETCDIR}/$$file; \
+ fi; \
+ done
.include <bsd.port.mk>