aboutsummaryrefslogtreecommitdiff
path: root/www/privoxy+ipv6
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-15 10:01:26 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-15 10:01:26 +0000
commite017a80a0e9f4ebd0267b77e0811964c822cdd15 (patch)
tree5d43b851ae9e6a273918df0fc2bfc30cf550c500 /www/privoxy+ipv6
parent3c9ecc4516917c2fb49723612d44fae8b362d752 (diff)
downloadports-e017a80a0e9f4ebd0267b77e0811964c822cdd15.tar.gz
ports-e017a80a0e9f4ebd0267b77e0811964c822cdd15.zip
Notes
Diffstat (limited to 'www/privoxy+ipv6')
-rw-r--r--www/privoxy+ipv6/Makefile72
-rw-r--r--www/privoxy+ipv6/distinfo2
-rw-r--r--www/privoxy+ipv6/files/patch-GNUmakefile.in27
-rw-r--r--www/privoxy+ipv6/files/patch-configure.in141
-rw-r--r--www/privoxy+ipv6/pkg-descr3
-rw-r--r--www/privoxy+ipv6/pkg-plist78
6 files changed, 117 insertions, 206 deletions
diff --git a/www/privoxy+ipv6/Makefile b/www/privoxy+ipv6/Makefile
index f27630f1128b..e22b50696c2e 100644
--- a/www/privoxy+ipv6/Makefile
+++ b/www/privoxy+ipv6/Makefile
@@ -1,63 +1,47 @@
-# New ports collection makefile for: privoxy
-# Date created: 21 November 2002
-# Whom: John von Essen
+# New ports collection makefile for: privoxy+ipv6
+# Date created: 17 June 2003
+# Whom: Lars Eggert
#
# $FreeBSD$
#
-PORTNAME= privoxy
-PORTVERSION= 3.0.0
-CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ijbswa
-DISTNAME= privoxy-3.0.0-stable-src
+PORTNAME= privoxy+ipv6
+PORTVERSION= 20030523
+CATEGORIES= www ipv6
+MASTER_SITES= ftp://ftp.deepspace6.net/pub/sources/privoxy/
+DISTNAME= privoxy_CVS_${PORTVERSION}_ipv6_5
-MAINTAINER= john@essenz.com
+MAINTAINER= larse@isi.edu
COMMENT= Privoxy is a web proxy with advanced filtering capabilities
-WRKSRC= ${WRKDIR}/privoxy-3.0.0-stable
+WRKSRC= ${WRKDIR}/privoxy
-PKGMESSAGE= ${WRKDIR}/pkg-message
+ETCDIR= ${PREFIX}/etc/privoxy
+USER= nobody
+GROUP= nobody
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+ipv6//}
+USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
+USE_AUTOCONF= yes
USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-user=${USER} --with-group=${GROUP} \
+ --sysconfdir=${ETCDIR} --localstatedir=/var
+
MAKEFILE= GNUmakefile
MAN1= privoxy.1
-post-patch:
- ${REINPLACE_CMD} \
- -e 's,^\(confdir\) \.,\1 ${PREFIX}/etc/privoxy,' \
- -e 's,^\(logdir\) \.,\1 /tmp,' \
- -e 's,^\(actionsfile standard\),#\1,' \
- -e 's,^\(actionsfile user\),#\1,' \
- ${WRKSRC}/config
-
-pre-configure:
- @cd ${WRKSRC}; ${AUTOHEADER}
-
-pre-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- ${PKGDIR}/pkg-message.in > ${PKGMESSAGE}
-
-do-install:
- @${MKDIR} ${PREFIX}/etc/privoxy/templates
- @${INSTALL_PROGRAM} ${WRKSRC}/privoxy ${PREFIX}/sbin
- @${INSTALL_DATA} ${WRKSRC}/templates/[a-z]* ${PREFIX}/etc/privoxy/templates
-.for file in config default.action default.filter trust
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/etc/privoxy
-.endfor
- @${INSTALL_MAN} ${WRKSRC}/privoxy.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/privoxy-manual
- @if [ -d ${WRKSRC}/doc/webserver/user-manual ]; then \
- ${INSTALL_DATA} ${WRKSRC}/doc/webserver/user-manual/[a-z]* ${PREFIX}/share/doc/privoxy-manual; \
- fi
-.endif
-
post-install:
- @${CAT} ${PKGMESSAGE}
+ @for file in config user.action; do \
+ if [ ! -f ${ETCDIR}/$$file ]; then \
+ ${CP} ${ETCDIR}/$$file.sample ${ETCDIR}/$$file; \
+ ${CHOWN} ${USER}:${GROUP} ${ETCDIR}/$$file; \
+ ${CHMOD} ug+rw ${ETCDIR}/$$file; \
+ fi; \
+ done
.include <bsd.port.mk>
diff --git a/www/privoxy+ipv6/distinfo b/www/privoxy+ipv6/distinfo
index 008464342c44..7542fb9ef6c5 100644
--- a/www/privoxy+ipv6/distinfo
+++ b/www/privoxy+ipv6/distinfo
@@ -1 +1 @@
-MD5 (privoxy-3.0.0-stable-src.tar.gz) = 6790def33b3e5ade2aa576347aa3cd4c
+MD5 (privoxy_CVS_20030523_ipv6_5.tar.bz2) = 61cd5123cc23c7c822404ddb9a5a4c8f
diff --git a/www/privoxy+ipv6/files/patch-GNUmakefile.in b/www/privoxy+ipv6/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..cfd22fd300e0
--- /dev/null
+++ b/www/privoxy+ipv6/files/patch-GNUmakefile.in
@@ -0,0 +1,27 @@
+--- GNUmakefile.in.orig Fri May 23 04:31:48 2003
++++ GNUmakefile.in Fri Jun 20 22:50:22 2003
+@@ -174,7 +174,7 @@
+ #############################################################################
+ # We include these files in our distributions
+ #############################################################################
+-CONFIGS = config trust default.action standard.action user.action default.filter
++CONFIGS = config.sample trust default.action standard.action user.action.sample default.filter
+ # take care that no CVS .cvsignore or other crappy files
+ # are included here
+ # and escape every '#' in the find. doh.
+@@ -945,10 +945,12 @@
+ $(CAT) config >config~ ;\
+ $(MV) config.base config ;\
+ fi
+- $(SED) 's+confdir .+confdir $(CONF_DEST)+' config | \
+- $(SED) 's+logdir .+logdir $(LOG_DEST)+' >config.updated
++ $(SED) 's+confdir .*+confdir $(CONF_DEST)+' config | \
++ $(SED) 's+logdir .*+logdir $(LOG_DEST)+' >config.updated
+ $(MV) config config.base
+- $(MV) config.updated config
++ $(MV) config.updated config
++ $(MV) config config.sample
++ $(CP) user.action user.action.sample
+
+ @# Install the config support files. Test for root install, and abort
+ @# if there is no privoxy user, and no other user or group was enabled
diff --git a/www/privoxy+ipv6/files/patch-configure.in b/www/privoxy+ipv6/files/patch-configure.in
deleted file mode 100644
index 9282cad4e9b3..000000000000
--- a/www/privoxy+ipv6/files/patch-configure.in
+++ /dev/null
@@ -1,141 +0,0 @@
--- Patch by Lars Eggert <larse@isi.edu> USC Information Sciences Institute
---- configure.in.orig Fri Feb 20 17:15:20 2003
-+++ configure.in Fri Feb 20 17:15:51 2003
-@@ -726,137 +726,6 @@
- AC_SUBST(PTHREAD_ONLY)
-
- dnl =================================================================
--dnl Support for thread-safe versions of gethostbyaddr, gethostbyname,
--dnl gmtime and localtime
--dnl =================================================================
--
--dnl Next line needed to find the gethost*_r functions on Solaris
--AC_CHECK_LIB(nsl, gethostbyname)
--
--AC_CHECK_FUNC(gethostbyaddr_r, [
-- AC_MSG_CHECKING([signature of gethostbyaddr_r])
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent *h, *hp;
-- char *a, *b;
-- int l, bl, t, e;
-- (void) gethostbyaddr_r(a, l, t, h, b, bl, &hp, &e)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYADDR_R_8_ARGS)
-- AC_MSG_RESULT([8 args])
-- ], [
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent *h;
-- char *a, *b;
-- int l, bl, t, e;
-- (void) gethostbyaddr_r(a, l, t, h, b, bl, &e)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYADDR_R_7_ARGS)
-- AC_MSG_RESULT([7 args])
-- ], [
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent_data *d;
-- struct hostent *h;
-- char a,
-- int l, t;
-- (void) gethostbyaddr_r(a, l, t, h, d)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYADDR_R_5_ARGS)
-- AC_MSG_RESULT([5 args])
-- ], [
-- AC_MSG_RESULT(unrecognised)
-- ])
-- ])
-- ])
--], [
-- AC_MSG_RESULT(no)
--])
--
--AC_CHECK_FUNC(gethostbyname_r, [
-- AC_MSG_CHECKING([signature of gethostbyname_r])
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent *h, *r;
-- char *n, *b;
-- int bl, e;
-- (void) gethostbyname_r(n, h, b, bl, &r, &e)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYNAME_R_6_ARGS)
-- AC_MSG_RESULT([6 args])
-- ], [
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent *h;
-- char *n, *b;
-- int bl, e;
-- (void) gethostbyname_r(n, h, b, bl, &e)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYNAME_R_5_ARGS)
-- AC_MSG_RESULT([5 args])
-- ], [
-- AC_TRY_COMPILE([
--# include <netdb.h>
-- ], [
-- struct hostent_data *d;
-- struct hostent *h;
-- char *n,
-- (void) gethostbyname_r(n, h, d)
-- ], [
-- AC_DEFINE(HAVE_GETHOSTBYNAME_R_3_ARGS)
-- AC_MSG_RESULT([3 args])
-- ], [
-- AC_MSG_RESULT(unrecognised)
-- ])
-- ])
-- ])
--], [
-- AC_MSG_RESULT(no)
--])
--
--AC_CHECK_FUNC(gmtime_r, [
-- AC_MSG_CHECKING([signature of gmtime_r])
-- AC_TRY_COMPILE([
--# include <time.h>
-- ], [
-- struct time *t;
-- struct tm *tm;
-- (void) gmtime_r(t, tm)
-- ], [
-- AC_MSG_RESULT(ok)
-- AC_DEFINE(HAVE_GMTIME_R)
-- ], [
-- AC_MSG_RESULT(unrecognised)
-- ])
--], [
-- AC_MSG_RESULT(no)
--])
--
--AC_CHECK_FUNC(localtime_r, [
-- AC_MSG_CHECKING([signature of localtime_r])
-- AC_TRY_COMPILE([
--# include <time.h>
-- ], [
-- struct time *t;
-- struct tm *tm;
-- (void) localtime_r(t, tm)
-- ], [
-- AC_MSG_RESULT(ok)
-- AC_DEFINE(HAVE_LOCALTIME_R)
-- ], [
-- AC_MSG_RESULT(unrecognised)
-- ])
--], [
-- AC_MSG_RESULT(no)
--])
--
--dnl =================================================================
- dnl Solaris specific
- dnl FIXME: Not tested on Solaris yet...
- dnl ISFIXED: Have tested it on Solaris, but there are other ways to
diff --git a/www/privoxy+ipv6/pkg-descr b/www/privoxy+ipv6/pkg-descr
index c99bb36d48ac..1a58c7d1de12 100644
--- a/www/privoxy+ipv6/pkg-descr
+++ b/www/privoxy+ipv6/pkg-descr
@@ -5,4 +5,7 @@ Privoxy has a very flexible configuration and can be customized to suit
individual needs and tastes. Privoxy has application for both stand-alone
systems and multi-user networks.
+This is a port of Lionel Mamane's patched CVS version that supports IPv6.
+
WWW: http://www.privoxy.org/
+WWW: http://www.deepspace6.net/sections/sources.html
diff --git a/www/privoxy+ipv6/pkg-plist b/www/privoxy+ipv6/pkg-plist
index 8ba4d147f950..af9044ddb34f 100644
--- a/www/privoxy+ipv6/pkg-plist
+++ b/www/privoxy+ipv6/pkg-plist
@@ -1,8 +1,10 @@
-sbin/privoxy
-etc/privoxy/config
+etc/privoxy/config.sample
etc/privoxy/default.action
etc/privoxy/default.filter
-etc/privoxy/trust
+etc/privoxy/standard.action
+etc/privoxy/templates/Entries
+etc/privoxy/templates/Repository
+etc/privoxy/templates/Root
etc/privoxy/templates/blocked
etc/privoxy/templates/cgi-error-404
etc/privoxy/templates/cgi-error-bad-param
@@ -36,21 +38,57 @@ etc/privoxy/templates/show-version
etc/privoxy/templates/toggle
etc/privoxy/templates/toggle-mini
etc/privoxy/templates/untrusted
-%%PORTDOCS%%share/doc/privoxy-manual/actions-file.html
-%%PORTDOCS%%share/doc/privoxy-manual/configuration.html
-%%PORTDOCS%%share/doc/privoxy-manual/filter-file.html
-%%PORTDOCS%%share/doc/privoxy-manual/introduction.html
-%%PORTDOCS%%share/doc/privoxy-manual/startup.html
-%%PORTDOCS%%share/doc/privoxy-manual/appendix.html
-%%PORTDOCS%%share/doc/privoxy-manual/contact.html
-%%PORTDOCS%%share/doc/privoxy-manual/index.html
-%%PORTDOCS%%share/doc/privoxy-manual/quickstart.html
-%%PORTDOCS%%share/doc/privoxy-manual/templates.html
-%%PORTDOCS%%share/doc/privoxy-manual/config.html
-%%PORTDOCS%%share/doc/privoxy-manual/copyright.html
-%%PORTDOCS%%share/doc/privoxy-manual/installation.html
-%%PORTDOCS%%share/doc/privoxy-manual/seealso.html
-%%PORTDOCS%%share/doc/privoxy-manual/upgradersnote.html
-%%PORTDOCS%%@dirrm share/doc/privoxy-manual
+etc/privoxy/trust
+etc/privoxy/user.action.sample
+sbin/privoxy
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/LICENSE
+%%DOCSDIR%%/README
+%%DOCSDIR%%/developer-manual/coding.html
+%%DOCSDIR%%/developer-manual/contact.html
+%%DOCSDIR%%/developer-manual/copyright.html
+%%DOCSDIR%%/developer-manual/cvs.html
+%%DOCSDIR%%/developer-manual/documentation.html
+%%DOCSDIR%%/developer-manual/index.html
+%%DOCSDIR%%/developer-manual/introduction.html
+%%DOCSDIR%%/developer-manual/newrelease.html
+%%DOCSDIR%%/developer-manual/seealso.html
+%%DOCSDIR%%/developer-manual/testing.html
+%%DOCSDIR%%/developer-manual/webserver-update.html
+%%DOCSDIR%%/faq/configuration.html
+%%DOCSDIR%%/faq/contact.html
+%%DOCSDIR%%/faq/copyright.html
+%%DOCSDIR%%/faq/general.html
+%%DOCSDIR%%/faq/index.html
+%%DOCSDIR%%/faq/installation.html
+%%DOCSDIR%%/faq/misc.html
+%%DOCSDIR%%/faq/trouble.html
+%%DOCSDIR%%/images/files-in-use.jpg
+%%DOCSDIR%%/images/proxy_setup.jpg
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/man-page/privoxy-man-page.html
+%%DOCSDIR%%/p_doc.css
+%%DOCSDIR%%/user-manual/actions-file.html
+%%DOCSDIR%%/user-manual/appendix.html
+%%DOCSDIR%%/user-manual/config.html
+%%DOCSDIR%%/user-manual/configuration.html
+%%DOCSDIR%%/user-manual/contact.html
+%%DOCSDIR%%/user-manual/copyright.html
+%%DOCSDIR%%/user-manual/filter-file.html
+%%DOCSDIR%%/user-manual/index.html
+%%DOCSDIR%%/user-manual/installation.html
+%%DOCSDIR%%/user-manual/introduction.html
+%%DOCSDIR%%/user-manual/quickstart.html
+%%DOCSDIR%%/user-manual/seealso.html
+%%DOCSDIR%%/user-manual/startup.html
+%%DOCSDIR%%/user-manual/templates.html
+%%DOCSDIR%%/user-manual/upgradersnote.html
@dirrm etc/privoxy/templates
-@dirrm etc/privoxy
+@dirrm %%DOCSDIR%%/developer-manual
+@dirrm %%DOCSDIR%%/faq
+@dirrm %%DOCSDIR%%/images
+@dirrm %%DOCSDIR%%/man-page
+@dirrm %%DOCSDIR%%/user-manual
+@dirrm %%DOCSDIR%%
+