aboutsummaryrefslogtreecommitdiff
path: root/www/privoxy
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-25 15:44:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-25 15:44:02 +0000
commitbcd0d22a1378f7ea33769a9e50ee9bb8c0e9a71b (patch)
tree76352729d12c1357d838e766b7252308bade440d /www/privoxy
parentfb194239f65a818bd0b4a31889ea8e3ea7e778f8 (diff)
downloadports-bcd0d22a1378f7ea33769a9e50ee9bb8c0e9a71b.tar.gz
ports-bcd0d22a1378f7ea33769a9e50ee9bb8c0e9a71b.zip
Notes
Diffstat (limited to 'www/privoxy')
-rw-r--r--www/privoxy/Makefile25
-rw-r--r--www/privoxy/distinfo6
-rw-r--r--www/privoxy/files/patch-cgi.c15
-rw-r--r--www/privoxy/files/patch-cgiedit.c32
-rw-r--r--www/privoxy/files/pkg-message.in51
-rw-r--r--www/privoxy/pkg-descr12
-rw-r--r--www/privoxy/pkg-plist52
7 files changed, 77 insertions, 116 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 0621bd14455a..24ed3cef080b 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= privoxy
-PORTVERSION= 3.0.6
-PORTREVISION= 2
+PORTVERSION= 3.0.8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ijbswa
@@ -16,6 +15,8 @@ DISTNAME= privoxy-${PORTVERSION}-stable-src
MAINTAINER= fk@fabiankeil.de
COMMENT= Privoxy is a web proxy with advanced filtering capabilities
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
USE_GMAKE= yes
@@ -32,6 +33,10 @@ CONFLICTS= privoxy-devel-[0-9]*
MAN1= privoxy.1
+CONFIGURE_ARGS= --enable-zlib
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib \
+ CPPFLAGS=-I${LOCALBASE}/include/
+
OPTIONS= FORCE "Allows to optionally bypass blocks" On \
TOGGLE "Support for remote toggling" On \
EDITOR "Enable webbased action editor" On \
@@ -63,7 +68,7 @@ post-patch:
${WRKSRC}/config
.if !defined(NOPORTDOCS)
${REINPLACE_CMD} \
- -e 's,^#\(user-manual\) http://www.privoxy.org/user-manual/,\1 ${PREFIX}/share/doc/privoxy-manual,' \
+ -e 's,^#\(user-manual\) http://www.privoxy.org/user-manual/,\1 ${DOCSDIR}/user-manual,' \
${WRKSRC}/config
.endif
@@ -84,17 +89,17 @@ do-install:
@${CHOWN} privoxy:privoxy ${PREFIX}/etc/privoxy/${defaultfile}
@${CHMOD} 0640 ${PREFIX}/etc/privoxy/${defaultfile}
.endfor
- @${MKDIR} ${PREFIX}/share/examples/privoxy
+ @${MKDIR} ${EXAMPLESDIR}
.for examplefile in config trust user.action
- @${INSTALL_DATA} ${WRKSRC}/${examplefile} ${PREFIX}/share/examples/privoxy
- @${CHOWN} privoxy:privoxy ${PREFIX}/share/examples/privoxy/${examplefile}
- @${CHMOD} 0640 ${PREFIX}/share/examples/privoxy/${examplefile}
+ @${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}/
+ @${CHOWN} privoxy:privoxy ${EXAMPLESDIR}/${examplefile}
+ @${CHMOD} 0640 ${EXAMPLESDIR}/${examplefile}
.endfor
@${INSTALL_MAN} ${WRKSRC}/privoxy.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/privoxy-manual
- @${INSTALL_DATA} ${WRKSRC}/doc/webserver/user-manual/[a-z]* ${PREFIX}/share/doc/privoxy-manual
- @${INSTALL_DATA} ${WRKSRC}/doc/webserver/p_doc.css ${PREFIX}/share/doc/privoxy-manual
+ @${MKDIR} ${DOCSDIR}/user-manual
+ @${INSTALL_DATA} ${WRKSRC}/doc/webserver/user-manual/[a-z]* ${DOCSDIR}/user-manual
+ @${INSTALL_DATA} ${WRKSRC}/doc/webserver/p_doc.css ${DOCSDIR}/user-manual
.endif
post-install:
diff --git a/www/privoxy/distinfo b/www/privoxy/distinfo
index 3a49ca9c4268..37567ba4c2c7 100644
--- a/www/privoxy/distinfo
+++ b/www/privoxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (privoxy-3.0.6-stable-src.tar.gz) = c3b34c620e1174f0c0b91aa2a04ceae4
-SHA256 (privoxy-3.0.6-stable-src.tar.gz) = 49e49d92d3b22c0fe730fef0f067668a51bb8a7aae53277ba709f301066e5dc0
-SIZE (privoxy-3.0.6-stable-src.tar.gz) = 1755661
+MD5 (privoxy-3.0.8-stable-src.tar.gz) = 252c0e085218fb930c4bc7563e9cedd9
+SHA256 (privoxy-3.0.8-stable-src.tar.gz) = ecd51cb2785691f4e90e07d147f5ec89a151b2e578f71afb26bdd90195478499
+SIZE (privoxy-3.0.8-stable-src.tar.gz) = 2007961
diff --git a/www/privoxy/files/patch-cgi.c b/www/privoxy/files/patch-cgi.c
deleted file mode 100644
index fdb6a1d31d4c..000000000000
--- a/www/privoxy/files/patch-cgi.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- cgi.c Mon Nov 13 20:05:50 2006
-+++ cgi.c Sat Dec 9 14:49:16 2006
-@@ -571,10 +579,12 @@
- "Look up which actions apply to a URL and why",
- TRUE },
- #ifdef FEATURE_CGI_EDIT_ACTIONS
-+#ifdef FEATURE_TOGGLE
- { "toggle",
- cgi_toggle,
- "Toggle Privoxy on or off",
- FALSE },
-+#endif /* def FEATURE_TOGGLE */
- { "edit-actions", /* Edit the actions list */
- cgi_edit_actions,
- NULL, FALSE },
diff --git a/www/privoxy/files/patch-cgiedit.c b/www/privoxy/files/patch-cgiedit.c
deleted file mode 100644
index 0d83b7b96ca3..000000000000
--- a/www/privoxy/files/patch-cgiedit.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- cgiedit.c Tue Jul 18 16:48:45 2006
-+++ cgiedit.c Sat Dec 9 14:49:16 2006
-@@ -333,8 +337,10 @@
- #include "miscutil.h"
- #include "errlog.h"
- #include "loaders.h"
--#include "loadcfg.h"
-+#ifdef FEATURE_TOGGLE
- /* loadcfg.h is for global_toggle_state only */
-+#include "loadcfg.h"
-+#endif /* def FEATURE_TOGGLE */
- #include "urlmatch.h"
-
- const char cgiedit_h_rcs[] = CGIEDIT_H_VERSION;
-@@ -4232,7 +4238,7 @@
- return cgi_redirect(rsp, target);
- }
-
--
-+#ifdef FEATURE_TOGGLE
- /*********************************************************************
- *
- * Function : cgi_toggle
-@@ -4300,7 +4306,7 @@
-
- return template_fill_for_cgi(csp, template_name, exports, rsp);
- }
--
-+#endif /* def FEATURE_TOGGLE */
-
- /*********************************************************************
- *
diff --git a/www/privoxy/files/pkg-message.in b/www/privoxy/files/pkg-message.in
index be30cf9ec574..2887e1a2ebd7 100644
--- a/www/privoxy/files/pkg-message.in
+++ b/www/privoxy/files/pkg-message.in
@@ -1,27 +1,28 @@
***********************************************************
-** To start Privoxy on boot, add: privoxy_enable="YES" **
-** to /etc/rc.conf. **
-** **
-** To start Privoxy manually, run: **
-** %%PREFIX%%/etc/rc.d/privoxy forcestart **
-** The script understands most of the commands listed **
-** in rc(8), it also contains a list of other rc **
-** variables you can use. **
-** **
-** Privoxy example files were copied to: **
-** %%PREFIX%%/share/examples/privoxy **
-** **
-** For documentation see: **
-** %%PREFIX%%/share/doc/privoxy-manual or 'man privoxy' **
-** **
-** Note that default.filter, standard.action and **
-** default.action get overwritten with each Privoxy **
-** update. Instead of changing them you should use **
-** your own action and filter files as described in **
-** Privoxy's manual. **
-** **
-** If you installed Privoxy as package and are using the **
-** default configuration, you have to make sure the **
-** directories /var/log/privoxy and /var/run/privoxy **
-** exist and are owned by privoxy:privoxy. **
+ To start Privoxy on boot, add: privoxy_enable="YES"
+ to /etc/rc.conf.
+
+ To start Privoxy manually, run:
+ /usr/local/etc/rc.d/privoxy forcestart
+ The script understands most of the commands listed
+ in rc(8), it also contains a list of other rc
+ variables you can use.
+
+ Privoxy's example files were copied to:
+ %%EXAMPLESDIR%%
+
+ For documentation see:
+ %%DOCSDIR%%/user-manual or 'man privoxy'
+
+ Note that default.filter, standard.action and
+ default.action get overwritten with each Privoxy
+ update. Instead of changing them you should use
+ your own action and filter files as described in
+ Privoxy's manual.
+
+ If you installed Privoxy as package and are using the
+ default configuration, you have to make sure the
+ directories /var/log/privoxy and /var/run/privoxy
+ exist and are owned by privoxy:privoxy.
+
***********************************************************
diff --git a/www/privoxy/pkg-descr b/www/privoxy/pkg-descr
index c99bb36d48ac..c64caa55e9c9 100644
--- a/www/privoxy/pkg-descr
+++ b/www/privoxy/pkg-descr
@@ -1,8 +1,8 @@
-Privoxy is a web proxy with advanced filtering capabilities for protecting
-privacy, filtering web page content, managing cookies, controlling access,
-and removing ads, banners, pop-ups and other obnoxious Internet junk.
-Privoxy has a very flexible configuration and can be customized to suit
-individual needs and tastes. Privoxy has application for both stand-alone
-systems and multi-user networks.
+Privoxy is a non-caching web proxy with advanced filtering capabilities for
+enhancing privacy, modifying web page data, managing HTTP cookies, controlling
+access, and removing ads, banners, pop-ups and other obnoxious Internet junk.
+Privoxy has a flexible configuration and can be customized to suit individual
+needs and tastes. Privoxy has application for both stand-alone systems and
+multi-user networks.
WWW: http://www.privoxy.org/
diff --git a/www/privoxy/pkg-plist b/www/privoxy/pkg-plist
index 0eb7723fcb67..4f3784ff9fd9 100644
--- a/www/privoxy/pkg-plist
+++ b/www/privoxy/pkg-plist
@@ -22,6 +22,7 @@ etc/privoxy/templates/edit-actions-list-section
etc/privoxy/templates/edit-actions-list-url
etc/privoxy/templates/edit-actions-remove-url-form
etc/privoxy/templates/edit-actions-url-form
+etc/privoxy/templates/forwarding-failed
etc/privoxy/templates/mod-local-help
etc/privoxy/templates/mod-support-and-service
etc/privoxy/templates/mod-title
@@ -35,30 +36,31 @@ etc/privoxy/templates/show-version
etc/privoxy/templates/toggle
etc/privoxy/templates/toggle-mini
etc/privoxy/templates/untrusted
-%%PORTDOCS%%share/doc/privoxy-manual/actions-file.html
-%%PORTDOCS%%share/doc/privoxy-manual/appendix.html
-%%PORTDOCS%%share/doc/privoxy-manual/config.html
-%%PORTDOCS%%share/doc/privoxy-manual/configuration.html
-%%PORTDOCS%%share/doc/privoxy-manual/contact.html
-%%PORTDOCS%%share/doc/privoxy-manual/copyright.html
-%%PORTDOCS%%share/doc/privoxy-manual/files-in-use.jpg
-%%PORTDOCS%%share/doc/privoxy-manual/filter-file.html
-%%PORTDOCS%%share/doc/privoxy-manual/index.html
-%%PORTDOCS%%share/doc/privoxy-manual/installation.html
-%%PORTDOCS%%share/doc/privoxy-manual/introduction.html
-%%PORTDOCS%%share/doc/privoxy-manual/p_doc.css
-%%PORTDOCS%%share/doc/privoxy-manual/proxy2.jpg
-%%PORTDOCS%%share/doc/privoxy-manual/proxy_setup.jpg
-%%PORTDOCS%%share/doc/privoxy-manual/quickstart.html
-%%PORTDOCS%%share/doc/privoxy-manual/seealso.html
-%%PORTDOCS%%share/doc/privoxy-manual/startup.html
-%%PORTDOCS%%share/doc/privoxy-manual/templates.html
-%%PORTDOCS%%share/doc/privoxy-manual/upgradersnote.html
-%%PORTDOCS%%share/doc/privoxy-manual/whatsnew.html
-share/examples/privoxy/config
-share/examples/privoxy/trust
-share/examples/privoxy/user.action
-@dirrm share/examples/privoxy
-%%PORTDOCS%%@dirrm share/doc/privoxy-manual
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/actions-file.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/appendix.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/config.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/contact.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/files-in-use.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/filter-file.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/p_doc.css
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/proxy2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/proxy_setup.jpg
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/seealso.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/startup.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/templates.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/upgradersnote.html
+%%PORTDOCS%%%%DOCSDIR%%/user-manual/whatsnew.html
+%%EXAMPLESDIR%%/config
+%%EXAMPLESDIR%%/trust
+%%EXAMPLESDIR%%/user.action
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/user-manual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/
@dirrm etc/privoxy/templates
@dirrm etc/privoxy