aboutsummaryrefslogtreecommitdiff
path: root/www/punbb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
commitb7df0651651ef059fd4db24d7b77113e72ad6c15 (patch)
treee492c56fa7379da1ca224d6c3b1e9a31bdf1f7d9 /www/punbb
parentf391ca611e4a642fc3b0e7df30f4a60b63f60b71 (diff)
Notes
Diffstat (limited to 'www/punbb')
-rw-r--r--www/punbb/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/www/punbb/Makefile b/www/punbb/Makefile
index 7e8baa46c436..5dbc32bd6aa6 100644
--- a/www/punbb/Makefile
+++ b/www/punbb/Makefile
@@ -26,12 +26,14 @@ NO_BUILD= yes
USE_PHP= yes
USE_BZIP2= yes
-OPTIONS= LANGUAGE_PACK "Install language packs" on \
- EXTRAS "Install all plugins available" on
+OPTIONS_DEFINE= LANGUAGE_PACK EXTRAS
+OPTIONS_DEFAULT= LANGUAGE_PACK EXTRAS
+LANGUAGE_PACK_DESC= Install language packs
+EXTRAS_DESC= Install all plugins available
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_LANGUAGE_PACK)
+.if ${PORT_OPTIONS:MLANGUAGE_PACK}
LANGFILES+= Arabic.zip \
Bangla_UTF8.zip \
Belarusian.zip \
@@ -87,7 +89,7 @@ PLIST_SUB+= LANGUAGE_PACK=""
PLIST_SUB+= LANGUAGE_PACK="@comment "
.endif
-.if defined(WITH_EXTRAS)
+.if ${PORT_OPTIONS:MEXTRAS}
PLUGINS+= AP_User_Merge.zip \
AP_Author_Update.zip \
AP_PunBB_Shell.zip \
@@ -129,4 +131,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>