aboutsummaryrefslogtreecommitdiff
path: root/www/py-WebError/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-09-21 08:18:54 +0000
committerWen Heping <wen@FreeBSD.org>2011-09-21 08:18:54 +0000
commit02104cfb87571c1e4d294aa5a24f3dea74a84550 (patch)
tree2b842a43875b9c6854a9ea3a39d7265190fe7587 /www/py-WebError/Makefile
parenta4c367e2ddc03be90235a43866545837e1120b56 (diff)
downloadports-02104cfb87571c1e4d294aa5a24f3dea74a84550.tar.gz
ports-02104cfb87571c1e4d294aa5a24f3dea74a84550.zip
Notes
Diffstat (limited to 'www/py-WebError/Makefile')
-rw-r--r--www/py-WebError/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/py-WebError/Makefile b/www/py-WebError/Makefile
index fe9a4db4250e..2c1a47a36492 100644
--- a/www/py-WebError/Makefile
+++ b/www/py-WebError/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WebError
PORTVERSION= 0.10.3
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,13 +15,20 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Web Error handling and exception catching
+LICENSE= MIT
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Paste>=1.7:${PORTSDIR}/www/py-paste \
${PYTHON_PKGNAMEPREFIX}pygments>=1.0:${PORTSDIR}/textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}Tempita>=0.3:${PORTSDIR}/textproc/py-Tempita \
- ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
+ ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob
USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 260
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
+.endif
+
+.include <bsd.port.post.mk>