aboutsummaryrefslogtreecommitdiff
path: root/www/py-bjoern
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-06-07 19:39:04 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-06-07 19:39:04 +0000
commitff8e9150094c72d3af741e12f7f48dbb1cdd42fd (patch)
tree81346430ff2fb5a27e0d5c00007182f2a58c6937 /www/py-bjoern
parentd5864ecd7e94c5f084d6b4ba67c8cc6ab58a6694 (diff)
downloadports-ff8e9150094c72d3af741e12f7f48dbb1cdd42fd.tar.gz
ports-ff8e9150094c72d3af741e12f7f48dbb1cdd42fd.zip
Notes
Diffstat (limited to 'www/py-bjoern')
-rw-r--r--www/py-bjoern/Makefile2
-rw-r--r--www/py-bjoern/distinfo4
-rw-r--r--www/py-bjoern/files/patch-bjoern__portable_sendfile.c44
3 files changed, 3 insertions, 47 deletions
diff --git a/www/py-bjoern/Makefile b/www/py-bjoern/Makefile
index 0b159df3541e..e1422a69e91f 100644
--- a/www/py-bjoern/Makefile
+++ b/www/py-bjoern/Makefile
@@ -3,7 +3,7 @@
#
PORTNAME= bjoern
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-bjoern/distinfo b/www/py-bjoern/distinfo
index 8ad42b90c49d..f7a31f4c122f 100644
--- a/www/py-bjoern/distinfo
+++ b/www/py-bjoern/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bjoern-1.3.1.tar.gz) = e21391c1f52c088554bf62ce54f8af2889412d41f44847ecf05495b6d0a6dd6e
-SIZE (bjoern-1.3.1.tar.gz) = 25811
+SHA256 (bjoern-1.3.2.tar.gz) = bb272517760897a96b3fbf0564236a4f9e0e14e05d8cdcc5f9ac2957ff0c89c0
+SIZE (bjoern-1.3.2.tar.gz) = 25878
diff --git a/www/py-bjoern/files/patch-bjoern__portable_sendfile.c b/www/py-bjoern/files/patch-bjoern__portable_sendfile.c
deleted file mode 100644
index 7600d2066609..000000000000
--- a/www/py-bjoern/files/patch-bjoern__portable_sendfile.c
+++ /dev/null
@@ -1,44 +0,0 @@
-See sendfile(2)
-
---- ./bjoern/portable_sendfile.c.orig 2012-07-23 14:46:30.000000000 +0000
-+++ ./bjoern/portable_sendfile.c 2013-06-02 18:17:34.000000000 +0000
-@@ -2,13 +2,16 @@
-
- #define SENDFILE_CHUNK_SIZE 16*1024
-
-+#if defined(__APPLE__) || defined(__FreeBSD__)
-+
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
-+ #include <sys/uio.h>
-+
- #ifdef __APPLE__
-
- /* OS X */
-
-- #include <sys/socket.h>
-- #include <sys/types.h>
--
- ssize_t portable_sendfile(int out_fd, int in_fd) {
- off_t len = SENDFILE_CHUNK_SIZE;
- if(sendfile(in_fd, out_fd, 0, &len, NULL, 0) == -1)
-@@ -18,6 +21,19 @@
-
- #else
-
-+ /* FreeBSD */
-+
-+ ssize_t portable_sendfile(int out_fd, int in_fd) {
-+ off_t len = SENDFILE_CHUNK_SIZE;
-+ if(sendfile(in_fd, out_fd, 0, SENDFILE_CHUNK_SIZE, NULL, &len, 0) == -1)
-+ return -1;
-+ return len;
-+ }
-+
-+#endif
-+
-+#else
-+
- /* Linux */
-
- #include <sys/sendfile.h>