aboutsummaryrefslogtreecommitdiff
path: root/www/py-cheroot/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-23 04:54:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-23 04:54:42 +0000
commit47488b243d749233884e009c8b17e7ec094b31e1 (patch)
tree5912cfca2724e416cc81498827b27ecdb95e5200 /www/py-cheroot/Makefile
parente1fcc343497c50ea8b3270b07b3975f47811823e (diff)
downloadports-47488b243d749233884e009c8b17e7ec094b31e1.tar.gz
ports-47488b243d749233884e009c8b17e7ec094b31e1.zip
Notes
Diffstat (limited to 'www/py-cheroot/Makefile')
-rw-r--r--www/py-cheroot/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/py-cheroot/Makefile b/www/py-cheroot/Makefile
new file mode 100644
index 000000000000..98071ecce764
--- /dev/null
+++ b/www/py-cheroot/Makefile
@@ -0,0 +1,24 @@
+# Created by: Keith Gaughan <k@stereochro.me>
+# $FreeBSD$
+
+PORTNAME= cheroot
+DISTVERSION= 6.0.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= k@stereochro.me
+COMMENT= Highly-optimized, pure-python HTTP server
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.0:devel/py-setuptools_scm@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>=2.6:devel/py-more-itertools@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>