aboutsummaryrefslogtreecommitdiff
path: root/www/py-cherrypy-devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-08 13:13:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-08 13:13:58 +0000
commit7dce5fe691f3c93bc7fd5d07847b13be733837d9 (patch)
tree785669b477eb84a1ddd60e44b75025e74cab17d6 /www/py-cherrypy-devel
parent918141936493c6f2e28142d484147b57b56cd288 (diff)
downloadports-7dce5fe691f3c93bc7fd5d07847b13be733837d9.tar.gz
ports-7dce5fe691f3c93bc7fd5d07847b13be733837d9.zip
Notes
Diffstat (limited to 'www/py-cherrypy-devel')
-rw-r--r--www/py-cherrypy-devel/Makefile13
-rw-r--r--www/py-cherrypy-devel/distinfo6
-rw-r--r--www/py-cherrypy-devel/pkg-plist109
3 files changed, 79 insertions, 49 deletions
diff --git a/www/py-cherrypy-devel/Makefile b/www/py-cherrypy-devel/Makefile
index c61adcbe052c..5982c3c329fd 100644
--- a/www/py-cherrypy-devel/Makefile
+++ b/www/py-cherrypy-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cherrypy
-PORTVERSION= 2.2.0.b
+PORTVERSION= 2.2.0
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,12 +20,23 @@ USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
LN_OPTS= -sf
+RM_OPTS= -r
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
CPEXAMPLES= ${PYTHON_SITELIBDIR}/${PORTNAME}/tutorial
+.if !defined(WITH_EXAMPLES)
+PLIST_SUB= PORTEXAMPLES="@comment "
+.else
+PLIST_SUB= PORTEXAMPLES=""
+.endif
+
post-install:
+.if !defined(WITH_EXAMPLES)
+ @${RM} ${RM_OPTS} ${CPEXAMPLES}
+.else
@${MV} ${CPEXAMPLES} ${EXAMPLESDIR} && \
${LN} ${LN_OPTS} ${EXAMPLESDIR} ${CPEXAMPLES}
+.endif
.include <bsd.port.mk>
diff --git a/www/py-cherrypy-devel/distinfo b/www/py-cherrypy-devel/distinfo
index 5648b162c499..09fee1feef71 100644
--- a/www/py-cherrypy-devel/distinfo
+++ b/www/py-cherrypy-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (CherryPy-2.2.0beta.tar.gz) = 58c14f2f3a3f1fe0f11d30f5c09b1f5c
-SHA256 (CherryPy-2.2.0beta.tar.gz) = c46548ba484f15c950d4a2e57798faecd67fee66bc440a1e9f93f5b19169f854
-SIZE (CherryPy-2.2.0beta.tar.gz) = 190251
+MD5 (CherryPy-2.2.0.tar.gz) = 13ea297f2f0c650cca856276a45ed29a
+SHA256 (CherryPy-2.2.0.tar.gz) = 3dd0e0dc2cdd0900d8f4a27fdb80fcdd98634f34aa00ad78b96e8e229f1f2b9b
+SIZE (CherryPy-2.2.0.tar.gz) = 221662
diff --git a/www/py-cherrypy-devel/pkg-plist b/www/py-cherrypy-devel/pkg-plist
index 68b27b879042..7a920973b35c 100644
--- a/www/py-cherrypy-devel/pkg-plist
+++ b/www/py-cherrypy-devel/pkg-plist
@@ -5,12 +5,12 @@
%%PYTHON_SITELIBDIR%%/cherrypy/_cpcgifs.py
%%PYTHON_SITELIBDIR%%/cherrypy/_cpcgifs.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/_cpcgifs.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/_cpengine.py
+%%PYTHON_SITELIBDIR%%/cherrypy/_cpengine.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/_cpengine.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/_cperror.py
%%PYTHON_SITELIBDIR%%/cherrypy/_cperror.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/_cperror.pyo
-%%PYTHON_SITELIBDIR%%/cherrypy/_cphttpserver.py
-%%PYTHON_SITELIBDIR%%/cherrypy/_cphttpserver.pyc
-%%PYTHON_SITELIBDIR%%/cherrypy/_cphttpserver.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/_cphttptools.py
%%PYTHON_SITELIBDIR%%/cherrypy/_cphttptools.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/_cphttptools.pyo
@@ -81,6 +81,9 @@
%%PYTHON_SITELIBDIR%%/cherrypy/filters/virtualhostfilter.py
%%PYTHON_SITELIBDIR%%/cherrypy/filters/virtualhostfilter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/filters/virtualhostfilter.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/filters/wsgiappfilter.py
+%%PYTHON_SITELIBDIR%%/cherrypy/filters/wsgiappfilter.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/filters/wsgiappfilter.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/filters/xmlrpcfilter.py
%%PYTHON_SITELIBDIR%%/cherrypy/filters/xmlrpcfilter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/filters/xmlrpcfilter.pyo
@@ -114,9 +117,19 @@
%%PYTHON_SITELIBDIR%%/cherrypy/test/__init__.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/__init__.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/benchmark.py
+%%PYTHON_SITELIBDIR%%/cherrypy/test/benchmark.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/test/benchmark.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/test/helper.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/helper.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/helper.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/modpy.py
+%%PYTHON_SITELIBDIR%%/cherrypy/test/modpy.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/test/modpy.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/standalone_test_alt_script_name.py
+%%PYTHON_SITELIBDIR%%/cherrypy/test/standalone_test_alt_script_name.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/test/standalone_test_alt_script_name.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/static/dirback.jpg
%%PYTHON_SITELIBDIR%%/cherrypy/test/static/has space.html
%%PYTHON_SITELIBDIR%%/cherrypy/test/static/index.html
%%PYTHON_SITELIBDIR%%/cherrypy/test/style.css
@@ -147,6 +160,9 @@
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_gzip_filter.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_gzip_filter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_gzip_filter.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_http.py
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_http.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_http.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_logdebuginfo_filter.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_logdebuginfo_filter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_logdebuginfo_filter.pyo
@@ -180,57 +196,60 @@
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_virtualhost_filter.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_virtualhost_filter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_virtualhost_filter.pyo
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_wsgiapp_filter.py
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_wsgiapp_filter.pyc
+%%PYTHON_SITELIBDIR%%/cherrypy/test/test_wsgiapp_filter.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_xmlrpc_filter.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_xmlrpc_filter.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/test_xmlrpc_filter.pyo
%%PYTHON_SITELIBDIR%%/cherrypy/test/webtest.py
%%PYTHON_SITELIBDIR%%/cherrypy/test/webtest.pyc
%%PYTHON_SITELIBDIR%%/cherrypy/test/webtest.pyo
-%%PYTHON_SITELIBDIR%%/cherrypy/tutorial
-%%EXAMPLESDIR%%/README.txt
-%%EXAMPLESDIR%%/__init__.py
-%%EXAMPLESDIR%%/__init__.pyc
-%%EXAMPLESDIR%%/__init__.pyo
-%%EXAMPLESDIR%%/bonus-sqlobject.py
-%%EXAMPLESDIR%%/bonus-sqlobject.pyc
-%%EXAMPLESDIR%%/bonus-sqlobject.pyo
-%%EXAMPLESDIR%%/custom_error.html
-%%EXAMPLESDIR%%/pdf_file.pdf
-%%EXAMPLESDIR%%/tut01_helloworld.py
-%%EXAMPLESDIR%%/tut01_helloworld.pyc
-%%EXAMPLESDIR%%/tut01_helloworld.pyo
-%%EXAMPLESDIR%%/tut02_expose_methods.py
-%%EXAMPLESDIR%%/tut02_expose_methods.pyc
-%%EXAMPLESDIR%%/tut02_expose_methods.pyo
-%%EXAMPLESDIR%%/tut03_get_and_post.py
-%%EXAMPLESDIR%%/tut03_get_and_post.pyc
-%%EXAMPLESDIR%%/tut03_get_and_post.pyo
-%%EXAMPLESDIR%%/tut04_complex_site.py
-%%EXAMPLESDIR%%/tut04_complex_site.pyc
-%%EXAMPLESDIR%%/tut04_complex_site.pyo
-%%EXAMPLESDIR%%/tut05_derived_objects.py
-%%EXAMPLESDIR%%/tut05_derived_objects.pyc
-%%EXAMPLESDIR%%/tut05_derived_objects.pyo
-%%EXAMPLESDIR%%/tut06_default_method.py
-%%EXAMPLESDIR%%/tut06_default_method.pyc
-%%EXAMPLESDIR%%/tut06_default_method.pyo
-%%EXAMPLESDIR%%/tut07_sessions.py
-%%EXAMPLESDIR%%/tut07_sessions.pyc
-%%EXAMPLESDIR%%/tut07_sessions.pyo
-%%EXAMPLESDIR%%/tut08_generators_and_yield.py
-%%EXAMPLESDIR%%/tut08_generators_and_yield.pyc
-%%EXAMPLESDIR%%/tut08_generators_and_yield.pyo
-%%EXAMPLESDIR%%/tut09_files.py
-%%EXAMPLESDIR%%/tut09_files.pyc
-%%EXAMPLESDIR%%/tut09_files.pyo
-%%EXAMPLESDIR%%/tut10_http_errors.py
-%%EXAMPLESDIR%%/tut10_http_errors.pyc
-%%EXAMPLESDIR%%/tut10_http_errors.pyo
-%%EXAMPLESDIR%%/tutorial.conf
+%%PORTEXAMPLES%%%%PYTHON_SITELIBDIR%%/cherrypy/tutorial
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/__init__.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/__init__.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bonus-sqlobject.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bonus-sqlobject.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bonus-sqlobject.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/custom_error.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pdf_file.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut01_helloworld.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut01_helloworld.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut01_helloworld.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut02_expose_methods.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut02_expose_methods.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut02_expose_methods.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut03_get_and_post.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut03_get_and_post.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut03_get_and_post.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut04_complex_site.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut04_complex_site.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut04_complex_site.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut05_derived_objects.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut05_derived_objects.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut05_derived_objects.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut06_default_method.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut06_default_method.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut06_default_method.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut07_sessions.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut07_sessions.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut07_sessions.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut08_generators_and_yield.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut08_generators_and_yield.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut08_generators_and_yield.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut09_files.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut09_files.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut09_files.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut10_http_errors.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut10_http_errors.pyc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tut10_http_errors.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial.conf
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy/filters
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy/lib/filter
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy/lib
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy/test/static
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy/test
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%PYTHON_SITELIBDIR%%/cherrypy