aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-crispy-forms
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-02-02 08:10:14 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-02-02 08:10:14 +0000
commit3c26abd8d370be8afe3974015618b4b61951aa9a (patch)
treedaa7f824442ae907c5eb0071a7b561abfb8c7729 /www/py-django-crispy-forms
parente456aafbabe2e3710efdd485330915938e8780a1 (diff)
downloadports-3c26abd8d370be8afe3974015618b4b61951aa9a.tar.gz
ports-3c26abd8d370be8afe3974015618b4b61951aa9a.zip
Notes
Diffstat (limited to 'www/py-django-crispy-forms')
-rw-r--r--www/py-django-crispy-forms/Makefile22
-rw-r--r--www/py-django-crispy-forms/distinfo2
-rw-r--r--www/py-django-crispy-forms/pkg-descr6
3 files changed, 30 insertions, 0 deletions
diff --git a/www/py-django-crispy-forms/Makefile b/www/py-django-crispy-forms/Makefile
new file mode 100644
index 000000000000..9905f1e53162
--- /dev/null
+++ b/www/py-django-crispy-forms/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= crispy-forms
+PORTVERSION= 1.4.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
+DISTNAME= django-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= The best way to have Django DRY forms
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django<1.7:${PORTSDIR}/www/py-django
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-crispy-forms/distinfo b/www/py-django-crispy-forms/distinfo
new file mode 100644
index 000000000000..8fb1309eaaa5
--- /dev/null
+++ b/www/py-django-crispy-forms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-crispy-forms-1.4.0.tar.gz) = d0c9531ebdff8dc255f625e677ec2fab326522e3f4cd8f7a3e891d773d281510
+SIZE (django-crispy-forms-1.4.0.tar.gz) = 47444
diff --git a/www/py-django-crispy-forms/pkg-descr b/www/py-django-crispy-forms/pkg-descr
new file mode 100644
index 000000000000..f3ade1698bc1
--- /dev/null
+++ b/www/py-django-crispy-forms/pkg-descr
@@ -0,0 +1,6 @@
+The best way to have Django DRY forms. Build programmatic reusable layouts out
+of components, having full control of the rendered HTML without writing HTML in
+templates. All this without breaking the standard way of doing things in Django,
+so it plays nice with any other form application.
+
+WWW: https://github.com/maraujop/django-crispy-forms