aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-devel
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-10-16 16:48:20 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-10-16 16:48:20 +0000
commitfeadc63669ba4d1c6f85d3a554671cb4513ab273 (patch)
treee297bcdc52a5639fb0d8f8f8c4551798c980383c /www/py-django-devel
parent91474598d5084e44aea5a0363923d12840aad487 (diff)
downloadports-feadc63669ba4d1c6f85d3a554671cb4513ab273.tar.gz
ports-feadc63669ba4d1c6f85d3a554671cb4513ab273.zip
Notes
Diffstat (limited to 'www/py-django-devel')
-rw-r--r--www/py-django-devel/Makefile4
-rw-r--r--www/py-django-devel/distinfo6
-rw-r--r--www/py-django-devel/files/patch-sphinx109
-rw-r--r--www/py-django-devel/pkg-plist7
4 files changed, 11 insertions, 115 deletions
diff --git a/www/py-django-devel/Makefile b/www/py-django-devel/Makefile
index 85a8f02901bb..e78d522b86dd 100644
--- a/www/py-django-devel/Makefile
+++ b/www/py-django-devel/Makefile
@@ -20,7 +20,7 @@ DIST_SUBDIR= python
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= High-level Python Web framework
-REVISION= 10834
+REVISION= 11627
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -28,7 +28,7 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Django
-PYDISTUTILS_PKGVERSION= 1.1_beta_1
+PYDISTUTILS_PKGVERSION= 1.2_pre_alpha
CONFLICTS= py2[0-9]-django-[0-9]*
diff --git a/www/py-django-devel/distinfo b/www/py-django-devel/distinfo
index 1874eee11963..d58a74c24777 100644
--- a/www/py-django-devel/distinfo
+++ b/www/py-django-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (python/Django-r10834.tar.bz2) = 5471c8be3ec305d354fb2a2a917129aa
-SHA256 (python/Django-r10834.tar.bz2) = 5026baf57657a59bff311a7268e62738253e9bd917020db023cfd33e088f678c
-SIZE (python/Django-r10834.tar.bz2) = 4026669
+MD5 (python/Django-r11627.tar.bz2) = 06ee80697e17682edbd721217525e3b1
+SHA256 (python/Django-r11627.tar.bz2) = 9d32d4378b39a41da89fc6cea377d103efc9e153d00aeda0d9ca0f2701a4054b
+SIZE (python/Django-r11627.tar.bz2) = 4133747
diff --git a/www/py-django-devel/files/patch-sphinx b/www/py-django-devel/files/patch-sphinx
deleted file mode 100644
index 417343e0673c..000000000000
--- a/www/py-django-devel/files/patch-sphinx
+++ /dev/null
@@ -1,109 +0,0 @@
-Index: docs/_templates/layout.html
-===================================================================
---- docs/_templates/layout.html (revision 10461)
-+++ docs/_templates/layout.html (working copy)
-@@ -1,6 +1,6 @@
- {% extends "!layout.html" %}
-
--{%- macro secondnav %}
-+{%- macro secondnav() %}
- {%- if prev %}
- &laquo; <a href="{{ prev.link|e }}" title="{{ prev.title|e }}">previous</a>
- {{ reldelim2 }}
-Index: docs/_ext/djangodocs.py
-===================================================================
---- docs/_ext/djangodocs.py (revision 10461)
-+++ docs/_ext/djangodocs.py (working copy)
-@@ -2,6 +2,7 @@
- Sphinx plugins for Django documentation.
- """
-
-+import re
- import docutils.nodes
- import docutils.transforms
- import sphinx
-@@ -9,7 +10,7 @@
- import sphinx.builder
- import sphinx.directives
- import sphinx.environment
--import sphinx.htmlwriter
-+import sphinx.writers.html
- import sphinx.roles
- from docutils import nodes
-
-@@ -44,7 +45,7 @@
- directivename = "django-admin-option",
- rolename = "djadminopt",
- indextemplate = "pair: %s; django-admin command-line option",
-- parse_node = lambda env, sig, signode: sphinx.directives.parse_option_desc(signode, sig),
-+ parse_node = lambda env, sig, signode: parse_option_desc(signode, sig),
- )
- app.add_config_value('django_next_version', '0.0', True)
- app.add_directive('versionadded', parse_version_directive, 1, (1, 1, 1))
-@@ -55,6 +56,26 @@
- if sphinx.__version__ == '0.4.2':
- monkeypatch_pickle_builder()
-
-+option_desc_re = re.compile(
-+ r'((?:/|-|--)[-_a-zA-Z0-9]+)(\s*.*?)(?=,\s+(?:/|-|--)|$)')
-+
-+def parse_option_desc(signode, sig):
-+ """Transform an option description into RST nodes."""
-+ count = 0
-+ firstname = ''
-+ for m in option_desc_re.finditer(sig):
-+ optname, args = m.groups()
-+ if count:
-+ signode += sphinx.addnodes.desc_addname(', ', ', ')
-+ signode += sphinx.addnodes.desc_name(optname, optname)
-+ signode += sphinx.addnodes.desc_addname(args, args)
-+ if not count:
-+ firstname = optname
-+ count += 1
-+ if not firstname:
-+ raise ValueError
-+ return firstname
-+
- def parse_version_directive(name, arguments, options, content, lineno,
- content_offset, block_text, state, state_machine):
- env = state.document.settings.env
-@@ -102,7 +123,7 @@
- if len(node.children) == 1 and isinstance(node.children[0], self.suppress_blockquote_child_nodes):
- node.replace_self(node.children[0])
-
--class DjangoHTMLTranslator(sphinx.htmlwriter.SmartyPantsHTMLTranslator):
-+class DjangoHTMLTranslator(sphinx.writers.html.SmartyPantsHTMLTranslator):
- """
- Django-specific reST to HTML tweaks.
- """
-@@ -125,10 +146,10 @@
- #
- def visit_literal_block(self, node):
- self.no_smarty += 1
-- sphinx.htmlwriter.SmartyPantsHTMLTranslator.visit_literal_block(self, node)
-+ sphinx.writers.html.SmartyPantsHTMLTranslator.visit_literal_block(self, node)
-
- def depart_literal_block(self, node):
-- sphinx.htmlwriter.SmartyPantsHTMLTranslator.depart_literal_block(self, node)
-+ sphinx.writers.html.SmartyPantsHTMLTranslator.depart_literal_block(self, node)
- self.no_smarty -= 1
-
- #
-@@ -162,7 +183,7 @@
- # Give each section a unique ID -- nice for custom CSS hooks
- # This is different on docutils 0.5 vs. 0.4...
-
-- if hasattr(sphinx.htmlwriter.SmartyPantsHTMLTranslator, 'start_tag_with_title') and sphinx.__version__ == '0.4.2':
-+ if hasattr(sphinx.writers.html.SmartyPantsHTMLTranslator, 'start_tag_with_title') and sphinx.__version__ == '0.4.2':
- def start_tag_with_title(self, node, tagname, **atts):
- node = {
- 'classes': node.get('classes', []),
-@@ -176,7 +197,7 @@
- node['ids'] = ['s-' + i for i in old_ids]
- if sphinx.__version__ != '0.4.2':
- node['ids'].extend(old_ids)
-- sphinx.htmlwriter.SmartyPantsHTMLTranslator.visit_section(self, node)
-+ sphinx.writers.html.SmartyPantsHTMLTranslator.visit_section(self, node)
- node['ids'] = old_ids
-
- def parse_django_admin_node(env, sig, signode):
diff --git a/www/py-django-devel/pkg-plist b/www/py-django-devel/pkg-plist
index 00d8e314df3f..96bd318af745 100644
--- a/www/py-django-devel/pkg-plist
+++ b/www/py-django-devel/pkg-plist
@@ -216,6 +216,10 @@ bin/django-admin.py
%%PYTHON_SITELIBDIR%%/django/conf/locale/sr/LC_MESSAGES/django.po
%%PYTHON_SITELIBDIR%%/django/conf/locale/sr/LC_MESSAGES/djangojs.mo
%%PYTHON_SITELIBDIR%%/django/conf/locale/sr/LC_MESSAGES/djangojs.po
+%%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn/LC_MESSAGES/djangojs.mo
+%%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn/LC_MESSAGES/djangojs.po
%%PYTHON_SITELIBDIR%%/django/conf/locale/sv/LC_MESSAGES/django.mo
%%PYTHON_SITELIBDIR%%/django/conf/locale/sv/LC_MESSAGES/django.po
%%PYTHON_SITELIBDIR%%/django/conf/locale/sv/LC_MESSAGES/djangojs.mo
@@ -1055,7 +1059,6 @@ bin/django-admin.py
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/admin/openlayers.js
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/admin/osm.html
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/admin/osm.js
-%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/google/google-base.js
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/google/google-map.html
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/google/google-map.js
%%PYTHON_SITELIBDIR%%/django/contrib/gis/templates/gis/google/google-multi.js
@@ -2491,6 +2494,8 @@ bin/django-admin.py
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/ta
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sv/LC_MESSAGES
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sv
+@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn/LC_MESSAGES
+@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sr_Latn
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sr/LC_MESSAGES
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sr
@dirrm %%PYTHON_SITELIBDIR%%/django/conf/locale/sl/LC_MESSAGES