aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-mptt
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2011-03-18 20:24:29 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2011-03-18 20:24:29 +0000
commitedb493f8b4a43010b678ea06c4ac5c1ef23b7a01 (patch)
treeabe21259247bae4ae2d89680f6b32c4e36df5e27 /www/py-django-mptt
parent3cfc42c667b81ca26335ea6b794ae26810813616 (diff)
downloadports-edb493f8b4a43010b678ea06c4ac5c1ef23b7a01.tar.gz
ports-edb493f8b4a43010b678ea06c4ac5c1ef23b7a01.zip
Notes
Diffstat (limited to 'www/py-django-mptt')
-rw-r--r--www/py-django-mptt/Makefile27
-rw-r--r--www/py-django-mptt/distinfo2
-rw-r--r--www/py-django-mptt/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/www/py-django-mptt/Makefile b/www/py-django-mptt/Makefile
new file mode 100644
index 000000000000..6414138d5131
--- /dev/null
+++ b/www/py-django-mptt/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: django-mptt
+# Date created: 2011-02-16
+# Whom: Carlo Strub
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-mptt
+PORTVERSION= 0.4.2
+CATEGORIES= www python
+MASTER_SITES= http://www.c-s.li/ports/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= c-s@c-s.li
+COMMENT= Utilities for implementing a pre-order traversal tree in django
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-7d3e111
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-django-mptt/distinfo b/www/py-django-mptt/distinfo
new file mode 100644
index 000000000000..9c42480190c6
--- /dev/null
+++ b/www/py-django-mptt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-mptt-0.4.2.tar.gz) = 5da78351ee7255d3f7a0a9112fa2542aba82d3de19abd98ecce858b28dbe776b
+SIZE (django-mptt-0.4.2.tar.gz) = 63197
diff --git a/www/py-django-mptt/pkg-descr b/www/py-django-mptt/pkg-descr
new file mode 100644
index 000000000000..efbbd3d5ca60
--- /dev/null
+++ b/www/py-django-mptt/pkg-descr
@@ -0,0 +1,4 @@
+Utilities for implementing Modified Preorder Tree Traversal with
+your Django Models and working with trees of Model instances.
+
+WWW: https://github.com/django-mptt/django-mptt/