aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-simple-history/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2015-12-28 22:50:04 +0000
committerCarlo Strub <cs@FreeBSD.org>2015-12-28 22:50:04 +0000
commitd5b12d2ebe027c6a49dae367ca3a9ce8f03442fe (patch)
tree8d2d507bf3114c07f8416ca1a16d0b924bbea701 /www/py-django-simple-history/Makefile
parent7be45bc5f2b079e2cac46aa7a5294d0d76fbb27d (diff)
django-simple-history stores Django model state on every create/update/delete.
Notes
Notes: svn path=/head/; revision=404697
Diffstat (limited to 'www/py-django-simple-history/Makefile')
-rw-r--r--www/py-django-simple-history/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/py-django-simple-history/Makefile b/www/py-django-simple-history/Makefile
new file mode 100644
index 000000000000..b693123b0150
--- /dev/null
+++ b/www/py-django-simple-history/Makefile
@@ -0,0 +1,24 @@
+# Created by: Carlo Strub
+# $FreeBSD$
+
+PORTNAME= django-simple-history
+PORTVERSION= 1.7.0
+CATEGORIES= www python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Store model history and view/revert changes from admin site
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django # >= 1.8
+
+USE_GITHUB= yes
+
+GH_ACCOUNT= treyhunner
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>