aboutsummaryrefslogtreecommitdiff
path: root/www/py-django
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-24 14:53:15 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-24 14:53:15 +0000
commit53500e63356515ef69739b0e9d933dae865d78f0 (patch)
treefc60fef3f983960fd394a6371336c733a222359e /www/py-django
parent6be649f424a23d9be13ac6d76cafd671fca72984 (diff)
downloadports-53500e63356515ef69739b0e9d933dae865d78f0.tar.gz
ports-53500e63356515ef69739b0e9d933dae865d78f0.zip
Notes
Diffstat (limited to 'www/py-django')
-rw-r--r--www/py-django/Makefile1
-rw-r--r--www/py-django/files/extra-patch-changeset_16223_16231.diff17
2 files changed, 18 insertions, 0 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index d9016006c7ef..4987a512f821 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -58,6 +58,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
.if defined(WITH_DOCS)
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-changeset_16223_16231.diff
PORTDOCS= *
.endif
diff --git a/www/py-django/files/extra-patch-changeset_16223_16231.diff b/www/py-django/files/extra-patch-changeset_16223_16231.diff
new file mode 100644
index 000000000000..8ff8fa6395a6
--- /dev/null
+++ b/www/py-django/files/extra-patch-changeset_16223_16231.diff
@@ -0,0 +1,17 @@
+--- docs/_ext/djangodocs.py.orig 2010-11-21 05:00:41.000000000 +0800
++++ docs/_ext/djangodocs.py 2011-12-24 22:37:54.866639407 +0800
+@@ -127,12 +127,14 @@
+
+ # Don't use border=1, which docutils does by default.
+ def visit_table(self, node):
++ self._table_row_index = 0 # Needed by Sphinx
+ self.body.append(self.starttag(node, 'table', CLASS='docutils'))
+
+ # <big>? Really?
+ def visit_desc_parameterlist(self, node):
+ self.body.append('(')
+ self.first_param = 1
++ self.param_separator = node.child_text_separator
+
+ def depart_desc_parameterlist(self, node):
+ self.body.append(')')