aboutsummaryrefslogtreecommitdiff
path: root/www/py-django
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-25 10:12:42 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-25 10:12:42 +0000
commit600314693a8a147f27249d9b75f0a3620ece78f8 (patch)
treef35761640d61a2fd2cd6db9bf24ec26f662a3366 /www/py-django
parent7f04abe72990577bfc998f62c68091bbe126100e (diff)
downloadports-600314693a8a147f27249d9b75f0a3620ece78f8.tar.gz
ports-600314693a8a147f27249d9b75f0a3620ece78f8.zip
Notes
Diffstat (limited to 'www/py-django')
-rw-r--r--www/py-django/Makefile34
-rw-r--r--www/py-django/distinfo4
-rw-r--r--www/py-django/pkg-descr2
-rw-r--r--www/py-django/pkg-plist3
4 files changed, 21 insertions, 22 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index a460610fd5b7..d02fb35479e3 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: django
-# Date created: 2005-11-19
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= django
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.2
CATEGORIES= www python
MASTER_SITES= https://www.djangoproject.com/m/releases/${PORTVERSION:R}/ \
CHEESESHOP
@@ -20,7 +16,7 @@ COMMENT= High-level Python Web framework
LICENSE= BSD
USE_GETTEXT= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Django
@@ -28,20 +24,20 @@ CONFLICTS= py2[0-9]-django-devel-[0-9]* py2[0-9]-django-1.[23].*
DOCSDIR= ${PREFIX}/share/doc/py-django
-OPTIONS_DEFINE= PGSQL MYSQL SQLITE FASTCGI HTMLDOCS
-OPTIONS_DEFAULT=
-
-HTMLDOCS_DESC= Build and install the HTML documentation (requires Sphinx)
-
-MAN1= daily_cleanup.1 django-admin.1 gather_profile_stats.1
-
# bypass infrastructure bug
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= FASTCGI HTMLDOCS
+OPTIONS_DEFAULT=SQLITE
+OPTIONS_MULTI= DATABASE
+OPTIONS_MULTI_DATABASE= PGSQL MYSQL SQLITE
+HTMLDOCS_DESC= Install the HTML documentation (requires Sphinx)
+
+MAN1= daily_cleanup.1 django-admin.1 gather_profile_stats.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPGSQL}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/_psycopg.so:${PORTSDIR}/databases/py-psycopg2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2
.endif
.if ${PORT_OPTIONS:MMYSQL}
@@ -49,7 +45,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MFASTCGI}
@@ -57,7 +53,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
.endif
.if ${PORT_OPTIONS:MHTMLDOCS}
-. if defined(NOPORTDOCS)
+. if empty(PORT_OPTIONS:MDOCS)
IGNORE= you cannot build documentation while setting NOPORTDOCS
. endif
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
@@ -79,4 +75,4 @@ post-install:
${CP} -R ${WRKSRC}/docs/_build/html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-django/distinfo b/www/py-django/distinfo
index 3958193eddfa..a4b32b90039f 100644
--- a/www/py-django/distinfo
+++ b/www/py-django/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Django-1.4.1.tar.gz) = 4d8d20eba350d3d29613cc5a6302d5c23730c7f9e150985bc58b3175b755409b
-SIZE (python/Django-1.4.1.tar.gz) = 7656756
+SHA256 (python/Django-1.4.2.tar.gz) = edfd8733f45bbaa524cee25bcac3080ce28c21242c27227464eae3fa6b3d80e7
+SIZE (python/Django-1.4.2.tar.gz) = 7722026
diff --git a/www/py-django/pkg-descr b/www/py-django/pkg-descr
index 4356d5ad924d..1eefec3fb492 100644
--- a/www/py-django/pkg-descr
+++ b/www/py-django/pkg-descr
@@ -7,4 +7,4 @@ intensive deadlines of a newsroom and the stringent requirements of experienced
Web developers. It has convenient niceties for developing content-management
systems, but it's an excellent tool for building any Web site.
-WWW: http://www.djangoproject.com/
+WWW: http://www.djangoproject.com/
diff --git a/www/py-django/pkg-plist b/www/py-django/pkg-plist
index de460b6bf767..c07c2ed69cb7 100644
--- a/www/py-django/pkg-plist
+++ b/www/py-django/pkg-plist
@@ -5294,6 +5294,9 @@ bin/django-admin.py
%%PYTHON_SITELIBDIR%%/django/utils/simplejson/tool.py
%%PYTHON_SITELIBDIR%%/django/utils/simplejson/tool.pyc
%%PYTHON_SITELIBDIR%%/django/utils/simplejson/tool.pyo
+%%PYTHON_SITELIBDIR%%/django/utils/six.py
+%%PYTHON_SITELIBDIR%%/django/utils/six.pyc
+%%PYTHON_SITELIBDIR%%/django/utils/six.pyo
%%PYTHON_SITELIBDIR%%/django/utils/synch.py
%%PYTHON_SITELIBDIR%%/django/utils/synch.pyc
%%PYTHON_SITELIBDIR%%/django/utils/synch.pyo