aboutsummaryrefslogtreecommitdiff
path: root/www/py-flask-restful/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-02-10 11:19:00 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-02-10 11:19:00 +0000
commit3fa7110e6728e273aa80403f310e68d1a61d1e74 (patch)
tree16ba8cb894b615a804cd3ff2bce9de60c68c31ee /www/py-flask-restful/Makefile
parent165a485bb0505d31fdfc0eb1d197ff0c340c9254 (diff)
downloadports-3fa7110e6728e273aa80403f310e68d1a61d1e74.tar.gz
ports-3fa7110e6728e273aa80403f310e68d1a61d1e74.zip
Notes
Diffstat (limited to 'www/py-flask-restful/Makefile')
-rw-r--r--www/py-flask-restful/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/www/py-flask-restful/Makefile b/www/py-flask-restful/Makefile
new file mode 100644
index 000000000000..eb3ac533de2d
--- /dev/null
+++ b/www/py-flask-restful/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= Flask-RESTful
+PORTVERSION= 0.3.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Simple framework for creating REST APIs with Flask
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aniso8601>0:${PORTSDIR}/devel/py-aniso8601 \
+ ${PYTHON_PKGNAMEPREFIX}Flask>0:${PORTSDIR}/www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>