aboutsummaryrefslogtreecommitdiff
path: root/www/py-html5lib
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-07-08 06:28:06 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-07-08 06:28:06 +0000
commit68c731f7929b49cfccc074f6ea01bc9e297ce73d (patch)
tree104635405fcd8a6a1f6bd6942c5cb4731ad13a36 /www/py-html5lib
parent1bf15ad3ed40cdf162657ca757ac086d10b2072a (diff)
downloadports-68c731f7929b49cfccc074f6ea01bc9e297ce73d.tar.gz
ports-68c731f7929b49cfccc074f6ea01bc9e297ce73d.zip
Notes
Diffstat (limited to 'www/py-html5lib')
-rw-r--r--www/py-html5lib/Makefile28
-rw-r--r--www/py-html5lib/distinfo2
2 files changed, 27 insertions, 3 deletions
diff --git a/www/py-html5lib/Makefile b/www/py-html5lib/Makefile
index 38e1d5ac6961..57b88f2b93ea 100644
--- a/www/py-html5lib/Makefile
+++ b/www/py-html5lib/Makefile
@@ -4,8 +4,9 @@
PORTNAME= html5lib
PORTVERSION= 0.999
CATEGORIES= www python
-MASTER_SITES= GOOGLE_CODE \
- CHEESESHOP
+MASTER_SITES= GOOGLE_CODE:master \
+ CHEESESHOP:master \
+ http://magemana.nl/ports/dist/:test
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rm@FreeBSD.org
@@ -13,8 +14,29 @@ COMMENT= Python based HTML parser based on the HTML5 spec
LICENSE= MIT
-USE_PYTHON= 2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+OPTIONS_DEFINE= TEST
+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+.include <bsd.port.options.mk>
+
+.if !empty(PORT_OPTIONS:MTEST)
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:master \
+ ${PORTNAME}-${PORTVERSION}-testdata${EXTRACT_SUFX}:test
+BUILD_DEPENDS+= ${TEST_DEPENDS}
+.endif
+
+regression-test: build
+ @${ECHO_MSG} "===> Testing ${PORTNAME} (patience...)"
+ @cd ${WRKSRC} && nosetests -q
+
+.if !empty(PORT_OPTIONS:MTEST)
+pre-install: regression-test
+.endif
+
.include <bsd.port.mk>
diff --git a/www/py-html5lib/distinfo b/www/py-html5lib/distinfo
index 1de8bee1f6f5..8a5b0bd70f64 100644
--- a/www/py-html5lib/distinfo
+++ b/www/py-html5lib/distinfo
@@ -1,2 +1,4 @@
SHA256 (html5lib-0.999.tar.gz) = c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e
SIZE (html5lib-0.999.tar.gz) = 885440
+SHA256 (html5lib-0.999-testdata.tar.gz) = 27c6b2d9668aecf893a34a25ce19af324d5d8ba3acd734ea2915321a3d03a9cd
+SIZE (html5lib-0.999-testdata.tar.gz) = 788956