aboutsummaryrefslogtreecommitdiff
path: root/www/py-http-parser
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2014-10-09 12:35:26 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2014-10-09 12:35:26 +0000
commit0ed6f4e1a0f527fc32267ff3de99f012e6bf62d0 (patch)
treed41ae727f2a3e7edda5033ac01038b887adbb404 /www/py-http-parser
parent63e77b8398fb931dca4560a34a016da2638fc6eb (diff)
Notes
Diffstat (limited to 'www/py-http-parser')
-rw-r--r--www/py-http-parser/Makefile21
-rw-r--r--www/py-http-parser/distinfo2
-rw-r--r--www/py-http-parser/pkg-descr5
3 files changed, 28 insertions, 0 deletions
diff --git a/www/py-http-parser/Makefile b/www/py-http-parser/Makefile
new file mode 100644
index 000000000000..727412088599
--- /dev/null
+++ b/www/py-http-parser/Makefile
@@ -0,0 +1,21 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http-parser
+PORTVERSION= 0.8.3
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= HTTP request/response parser for python in C
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-build:
+ @${STRIP_CMD} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/http_parser/parser.so
+
+.include <bsd.port.mk>
diff --git a/www/py-http-parser/distinfo b/www/py-http-parser/distinfo
new file mode 100644
index 000000000000..c1dbca95893e
--- /dev/null
+++ b/www/py-http-parser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (http-parser-0.8.3.tar.gz) = e2aff90a60def3e476bd71694d8757c0f95ebf2fedf0a8ae34ee306e0b20db83
+SIZE (http-parser-0.8.3.tar.gz) = 83040
diff --git a/www/py-http-parser/pkg-descr b/www/py-http-parser/pkg-descr
new file mode 100644
index 000000000000..6352f28069a7
--- /dev/null
+++ b/www/py-http-parser/pkg-descr
@@ -0,0 +1,5 @@
+HTTP request/response parser for Python compatible with Python 2.x (>=2.6),
+Python 3 and Pypy. If possible a C parser based on http-parser
+from Ryan Dahl will be used.
+
+WWW: https://github.com/benoitc/http-parser/