aboutsummaryrefslogtreecommitdiff
path: root/www/py-meld3
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-07 14:00:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-07 14:00:08 +0000
commitdcb8e9167b7ad5627d699eec925eb821240cd18e (patch)
treefcf8320856dd51b906a080ba501dfc25f5f33344 /www/py-meld3
parentd6eb4680a3c8b9fb60d0f0c6d318e1177b3348d8 (diff)
downloadports-dcb8e9167b7ad5627d699eec925eb821240cd18e.tar.gz
ports-dcb8e9167b7ad5627d699eec925eb821240cd18e.zip
Notes
Diffstat (limited to 'www/py-meld3')
-rw-r--r--www/py-meld3/Makefile39
-rw-r--r--www/py-meld3/distinfo3
-rw-r--r--www/py-meld3/pkg-descr19
3 files changed, 61 insertions, 0 deletions
diff --git a/www/py-meld3/Makefile b/www/py-meld3/Makefile
new file mode 100644
index 000000000000..6e1b7f965c27
--- /dev/null
+++ b/www/py-meld3/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: py-meld
+# Date created: 2 May 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meld
+PORTVERSION= 2.1.3
+CATEGORIES= www python
+MASTER_SITES= http://www.entrian.com/PyMeld/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyMeld
+EXTRACT_SUFX= .py
+EXTRACT_ONLY= # This space left intentionally empty
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A system for manipulating HTML using a Pythonic object model
+
+USE_PYTHON= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/PyMeld.py \
+ %%PYTHON_SITELIBDIR%%/PyMeld.pyc \
+ %%PYTHON_SITELIBDIR%%/PyMeld.pyo
+
+pre-build:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -OOOO -c 'import PyMeld' && \
+ ${PYTHON_CMD} -c 'import PyMeld'
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/PyMeld.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/PyMeld.pyc ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/PyMeld.pyo ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-meld3/distinfo b/www/py-meld3/distinfo
new file mode 100644
index 000000000000..83d3ee7c0e48
--- /dev/null
+++ b/www/py-meld3/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyMeld.py) = 2b12b14b4e7500dd9efae6da1c5ae6cf
+SHA256 (PyMeld.py) = 30e1c0adbe7f2f3e54aed05ca30cd61ddf8c5a57fa300331277a88e00617a5da
+SIZE (PyMeld.py) = 44917
diff --git a/www/py-meld3/pkg-descr b/www/py-meld3/pkg-descr
new file mode 100644
index 000000000000..464834ed8317
--- /dev/null
+++ b/www/py-meld3/pkg-descr
@@ -0,0 +1,19 @@
+A simple, lightweight system for manipulating HTML (and XML, informally) using
+a Pythonic object model.
+
+Features:
+ - Allows program logic and HTML to be completely separated - a graphical
+ designer can design the HTML in a visual HTML editor, without needing to
+ deal with any non-standard syntax or non-standard attribute names.
+ - Designed with common HTML-application programming tasks in mind.
+ - No special requirements for the HTML/XML (or just one: attribute values must
+ be quoted) - so you can use any editor, and your HTML/XML doesn't need to be
+ strictly valid.
+ - Works by string substitution, rather than by decomposing and rebuilding the
+ markup, hence has no impact on the parts of the page you don't manipulate.
+ - Does nothing but manipulating HTML/XML, hence fits in with any other Web
+ toolkits you're using.
+ - Tracebacks always point to the right place - many Python/HTML mixing systems
+ use exec or eval, making bugs hard to track down.
+
+WWW: http://www.entrian.com/PyMeld/index.html