aboutsummaryrefslogtreecommitdiff
path: root/www/py-mt
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-08 05:39:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-08 05:39:35 +0000
commit4d32b6b38c203ef3f278e1555ef133a121506e99 (patch)
tree57e5630ee269e6e4b7f3691e8a1a6b0a484bcdfd /www/py-mt
parent17fb6891556c463fb3d406722ef951581542709e (diff)
downloadports-4d32b6b38c203ef3f278e1555ef133a121506e99.tar.gz
ports-4d32b6b38c203ef3f278e1555ef133a121506e99.zip
Notes
Diffstat (limited to 'www/py-mt')
-rw-r--r--www/py-mt/Makefile26
-rw-r--r--www/py-mt/distinfo1
-rw-r--r--www/py-mt/pkg-descr12
-rw-r--r--www/py-mt/pkg-plist1
4 files changed, 40 insertions, 0 deletions
diff --git a/www/py-mt/Makefile b/www/py-mt/Makefile
new file mode 100644
index 000000000000..a37b05a9f637
--- /dev/null
+++ b/www/py-mt/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: PyMT
+# Date created: Dec 8, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mt
+PORTVERSION= 1.0
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pymt
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyMT-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Python module which provides Movable Type XML-RPC connectivity
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/PyMT.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-mt/distinfo b/www/py-mt/distinfo
new file mode 100644
index 000000000000..24693be9734d
--- /dev/null
+++ b/www/py-mt/distinfo
@@ -0,0 +1 @@
+MD5 (PyMT-1.0.tar.gz) = 9f3bf3c2f5b70c52a02f5a849c134b6e
diff --git a/www/py-mt/pkg-descr b/www/py-mt/pkg-descr
new file mode 100644
index 000000000000..be752fa83ac6
--- /dev/null
+++ b/www/py-mt/pkg-descr
@@ -0,0 +1,12 @@
+PyMT is a simple Python module which allows you to easily connect to a Movable
+Type weblog, using it's built in XML-RPC API. PyMT is capable of handling every
+MT call available.
+
+This interface allows you to access most of the core functionality of Movable
+Type, including the ability to view, post, delete and edit weblog entries,
+fetch user information, apply categories to your posts and get information
+about trackback pings. Every XML-RPC method is accessed using a PyMT method
+with exactly the same name. PyMT is basically just a light wrapper, which
+hides the xml-rpc part of the work.
+
+WWW: http://pymt.sourceforge.net/
diff --git a/www/py-mt/pkg-plist b/www/py-mt/pkg-plist
new file mode 100644
index 000000000000..dd6a4e60a05b
--- /dev/null
+++ b/www/py-mt/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/PyMT.py