aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.contentrules/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-02 09:57:06 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-02 09:57:06 +0000
commitd3680e41d3f3aad6dd2cc259dd2e9ebd5b121a8b (patch)
tree622239eee69307cacd2ec83c2eef1714730a5091 /www/py-plone.contentrules/Makefile
parentf800fe146e50e8e69df6ef82eb18ba38b8099dc2 (diff)
Notes
Diffstat (limited to 'www/py-plone.contentrules/Makefile')
-rw-r--r--www/py-plone.contentrules/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/py-plone.contentrules/Makefile b/www/py-plone.contentrules/Makefile
new file mode 100644
index 000000000000..4908b5fc1f99
--- /dev/null
+++ b/www/py-plone.contentrules/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: py-plone.contentrules
+# Date created: 02 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.contentrules
+PORTVERSION= 2.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Plone ContentRules Engine
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
+ ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope.annotation \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.componentvocabulary>=0:${PORTSDIR}/devel/py-zope.componentvocabulary \
+ ${PYTHON_PKGNAMEPREFIX}zope.configuration>=0:${PORTSDIR}/devel/py-zope.configuration \
+ ${PYTHON_PKGNAMEPREFIX}zope.container>=0:${PORTSDIR}/devel/py-zope.container \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>=0:${PORTSDIR}/devel/py-zope.lifecycleevent \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.testing>=0:${PORTSDIR}/devel/py-zope.testing
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+
+.include <bsd.port.mk>