aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.locking/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-25 10:46:22 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-25 10:46:22 +0000
commitaf45dc2ccad4649466e181213f3e7b3d0de61559 (patch)
tree097a430e11ec5471cea1849cd415514f393d6a05 /www/py-plone.locking/Makefile
parentebdc7b4aa5c6151503c9ce915f07a7278ecf3f50 (diff)
downloadports-af45dc2ccad4649466e181213f3e7b3d0de61559.tar.gz
ports-af45dc2ccad4649466e181213f3e7b3d0de61559.zip
Notes
Diffstat (limited to 'www/py-plone.locking/Makefile')
-rw-r--r--www/py-plone.locking/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/py-plone.locking/Makefile b/www/py-plone.locking/Makefile
new file mode 100644
index 000000000000..248ea4d1dcb5
--- /dev/null
+++ b/www/py-plone.locking/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: py-plone.locking
+# Date created: 25 December 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.locking
+PORTVERSION= 2.0.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= WebDAV locking support
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope.annotation \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.viewlet>=0:${PORTSDIR}/devel/py-zope.viewlet \
+ ${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition \
+ ${PYTHON_PKGNAMEPREFIX}DateTime>=0:${PORTSDIR}/devel/py-DateTime \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=0:${PORTSDIR}/devel/py-Products.CMFCore \
+ zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+#USE_ZOPE yes
+
+.include <bsd.port.mk>