aboutsummaryrefslogtreecommitdiff
path: root/www/py-pullparser
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-29 07:05:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-29 07:05:06 +0000
commit7057566a2bc1a8d4454e8a60b2d376a202d83935 (patch)
treec0c749bc3907e8e28ef06edfb7714a985555a35b /www/py-pullparser
parent3bbb880e64a498dcfb819ae560cee50c274bd407 (diff)
downloadports-7057566a2bc1a8d4454e8a60b2d376a202d83935.tar.gz
ports-7057566a2bc1a8d4454e8a60b2d376a202d83935.zip
Notes
Diffstat (limited to 'www/py-pullparser')
-rw-r--r--www/py-pullparser/Makefile22
-rw-r--r--www/py-pullparser/distinfo2
-rw-r--r--www/py-pullparser/pkg-descr5
-rw-r--r--www/py-pullparser/pkg-plist3
4 files changed, 32 insertions, 0 deletions
diff --git a/www/py-pullparser/Makefile b/www/py-pullparser/Makefile
new file mode 100644
index 000000000000..b65f1c5ff340
--- /dev/null
+++ b/www/py-pullparser/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# Ports collection makefile for: py-pullparser
+# Date created: Apr 29, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pullparser
+PORTVERSION= 0.0.5.b
+CATEGORIES= www python
+MASTER_SITES= http://wwwsearch.sourceforge.net/pullparser/src/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A simple "pull API" for HTML parsing
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-pullparser/distinfo b/www/py-pullparser/distinfo
new file mode 100644
index 000000000000..4eda1ca4b8a4
--- /dev/null
+++ b/www/py-pullparser/distinfo
@@ -0,0 +1,2 @@
+MD5 (pullparser-0.0.5b.tar.gz) = e4e238ead1d1e421cc5866c8e3f9153f
+SIZE (pullparser-0.0.5b.tar.gz) = 13895
diff --git a/www/py-pullparser/pkg-descr b/www/py-pullparser/pkg-descr
new file mode 100644
index 000000000000..d0864c3ba406
--- /dev/null
+++ b/www/py-pullparser/pkg-descr
@@ -0,0 +1,5 @@
+A simple "pull API" for HTML parsing, after Perl's HTML::TokeParser. Many
+simple HTML parsing tasks are simpler this way than with the HTMLParser
+module. pullparser.PullParser is a subclass of HTMLParser.HTMLParser.
+
+WWW: http://wwwsearch.sourceforge.net/pullparser/
diff --git a/www/py-pullparser/pkg-plist b/www/py-pullparser/pkg-plist
new file mode 100644
index 000000000000..18a80afb8f5c
--- /dev/null
+++ b/www/py-pullparser/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/pullparser.py
+%%PYTHON_SITELIBDIR%%/pullparser.pyc
+%%PYTHON_SITELIBDIR%%/pullparser.pyo